13 Replies Latest reply: Apr 16, 2012 5:06 PM by sojac RSS

    Sound, but no picture!

    pascalt

      Have sound, but no picture. Any ideas of problem?

        • Re: Sound, but no picture!
          willman500

          I'm having the same issue.  The last time I used my slingbox, a few weeks to a month ago, the video worked fine, but I went to use it yesterday and it wasn't working.  I'm using a Mac with snow leopard and when I went to watch the slingbox website said I needed to install a new plugin.

           

          After that issue I tried to view the slingbox on my windows machine and have the same issue, this time without having to install the new browser plugin.  I've only had my slingbox for a few months and it was purchased from Best Buy as new.

           

          Any insight on the issue would be great.

          • Re: Sound, but no picture!
            Apprentice

            Hi guys, this information may be useful, if not please feel free to provide more details about your set up.

             

            Watch on Slingbox.com plays audio but no video

            When I connect my set-top box to my TV with HDMI connections, I can't stream  video at all using any version of SlingPlayer. Why?

             

            Best regards,

            The Slingbox Answers Forum Moderator Team

            • Re: Sound, but no picture!
              JoeTBell

              My issue is when I turn off my tv, my slingbox only receives audio, but no video.  My TV must be on, and component selected, which is how my Slingbox is set up. If I select HDMI on my tv, I lose video...as well as when I turn off my tv.

               

              SO FRUSTRATING!!

              • Re: Sound, but no picture!
                bionicB

                if you have Comcast they are blocking the output video to Slingbox

                  • Re: Sound, but no picture!
                    jpbeatty1975

                    how do you know this about comcast????

                      • Re: Sound, but no picture!
                        alanrichey42 Master

                        It's not just Comcast.  I think the majority of TV Providers have now implemented HDCP on their devices, often via an Over-The-Air update to the firmware.  This prevents you having more than one HD output on your box, so if you use the HDMI output the component output is blocked.   As was pointed out, the solution is not to use HDMI but to use the component output to the Slingbox and then the component pass through to the TV.

                          • Re: Sound, but no picture!
                            sojac Newbie

                            You can still use the HDMI output, but only if you use an active HDMI cable, not a passive one. Here is a link to an active HDMI cable, which solves the problem. This is important to have still possibility to use a HDMI output as some materials (e.g. VoD) are never available in HD on the component output.

                              • Re: Sound, but no picture!
                                alanrichey42 Master

                                Can you tell us the difference between active and passive HDMI ?

                                 

                                I must admit I thought your solution was true only for those cases when you get the message along the lines of "..a non-compliant HD receiver is attached.." ?   There are lots of providors who actually disable the Component output completely if the HDMI output is used (in fact Sky in the UK don't even bother providing a secondary HD output now).  They do it to stop people recording protected HD content in accordance with the HDCP.

                                  • Re: Sound, but no picture!
                                    sojac Newbie

                                    I reffered to JoeTBell post:

                                     

                                    'My  issue is when I turn off my tv, my slingbox only receives audio, but no  video.  My TV must be on, and component selected, which is how my  Slingbox is set up. If I select HDMI on my tv, I lose video...as well as  when I turn off my tv.'

                                     

                                    This is not the case of switching off the component output by the provider.

                                     

                                    This is a typical problem of most STB, which protect their output with HDCP encryption. If you switch off the TV, it usually switches off its HDCP module. The STB detects then that there is non-HDCP compliant device connected to the HDMI output. In response the STB blocks most of his functions including the component outputs.

                                     

                                    Active iHDMI cables have an internal electronics, which hides for the STB the fact that the connected display switched off its HDCP registers, so STB doesn't block anything then.

                            • Re: Sound, but no picture!
                              primalurge

                              I am having same issue (comcast customer).  Everthing was fine until Apr 1st and then no more video.  Did comcast implement something starting in April

                            • Re: Sound, but no picture!
                              bionicB

                              solved my problem with sound working & video not working........disconnected my HDMI output from Comcast 8300HD box to tv & used component from box to tv.  Both tv & slingbox now working.