4 Replies Latest reply: Jan 30, 2011 4:28 PM by Cote RSS

    WAN OK, LAN No Good.

    Cote

      I'm pulling out my hair on this one guys. I've owned a Slingbox since the Classic days and been around networking and computers for a while, but maybe I'm just having a brain ****.

       

      Pro HD, newest firmware. 2.04.522 Slingplayer.

       

      I don't recall when this all started to break since I have used my Slingbox very infrequently.

       

      WAN is fine.

       

      LAN is No good on Windows XP machines (plural), but Win7 is fine. BIZARRE.

       

      Makes no sense, but it's a fact.

       

      I can ping the IP from the XP, I unplug the slingbox and it dies. Meaning: Okay, good connection, no duplicates local IP.

       

      It sees the Slingbox in the directory as a locally found device, but times out when you try to connect.

       

      It will work after X attempts, but Slingplayer reverts to the Amazon push TCP relay garbage. This is a new feature that Slingmedia added for people who don't know how to or can't port forward correctly.

       

      I can use the XP machine if I manually add a Slingbox in the directory with the WAN IP of my ISP, but that's obviously not how it should work.

       

      What am I doing wrong here? These computers are on the same switches, same ports, same subnet. The only difference if that two of them are XP (don't work) and 1 is a Win 7 machine.

       

      Any advice? Also, the properties tab will timeout too, UNLESS I am using the WAN IP, this information pops up instantly. I even turned off the firewall on one of the WinXP machines. Makes no sense. I tried 2.03.508 on the XP machine and it didn't work. I tried to downgrade the firmware on the Slinbox Pro, but it wouldn't go

        • Re: WAN OK, LAN No Good.
          menicos

          i have exactly the same problem! please advice once you get some answers

          • Re: WAN OK, LAN No Good.
            menicos

            fixed mine! just now.

             

            go to slingbox directory

            add another slingbox

            use IP address option

            use the Local LAN IP for connectivity!

             

            then just connect!

             

            works!

              • Re: WAN OK, LAN No Good.
                Cote

                Sorry, I've tried this already. I even went as far as doing a factory reset on the device.

                 

                I even removed all the switch gear and connected both XP machine and Slingbox with only the router in the middle and it still gives a timeout error.

                 

                Win 7, it worked fine. (and when I say works, I mean it works without your hack)

                 

                And as far as your solution is concerned, that's a temporary fix. It should work on the LAN without your workaround.

                 

                Does Slingmedia test with XP anymore?

              • Re: WAN OK, LAN No Good.
                Cote

                Wow, what a ride it has been...

                 

                Mind you, this is after I already did a factory reset.

                 

                I changed my router (Actiontec MI424WR) to an old Dlink 624 and it started to work!

                 

                Still  very odd. I then did a factory reset again, and put the Actiontec back  as the router. BUT this time I let Slingmedia pick the IP address where  as before I was going into the advance menu and specifically selecting  10.19.78.10. Sling picked 10.19.78.254. I didn't see a means to select  DHCP.

                 

                After I let Sling pick the IP, everything has been fine on my Windows XP machines.

                 

                This was AFTER I downgraded my firmware and used a slew of switch and cable configurations, and Slingplayer versions.

                 

                There  still is something very fishy going on and I think it might be a bug of  some sorts, but It may be overlooked since very few people go into the  advanced menu, use a 10.x address and use a MI424WR.

                 

                Hope this helps anyone else with similar timeout issues.