33 Replies Latest reply: Apr 11, 2012 1:33 PM by SweetLew0227 RSS

    PRO-HD: Microsoft Media Center Remote Not Working

    ACC413634

      After much troubleshooting I have managed to get my PRO-HD to do basic control of my XBOX 360 as a Windows Media Center Extender (see my previous post here to see the trials/tribulations I have been trying to sort out - https://community.sling.com/message/32312#32312).  However to achieve this I have had to setup the PRO-HD as though it is controlling a generic Microsoft device.  This is a highly unsatisfactory result.

       

      I STRONGLY desire to have the Media Center remote control (the grey one with a big green button in the middle and all the Media Center function buttons).  This works fine with my Slingbox Classic. Whereas the Slingbox Classic can be setup as a proper Media Center PVR complete with Guide listings and authentic Media Center remote control, the PRO-HD must be “dumbed down” to a basic device (“VCR”) to work at all.

       

      The specific setup that I desire to use for my PRO-HD – and the one that works properly on my Slingbox Classic – is achieved using the following settings during “Configure Video Sources” in the Sing Player setup wizard with the following selections:

      • Type of device: Standalone DVR
      • Manufacturer: Microsoft
      • Model: Media Center

       

      The “dumbed down” settings I am having to use to get the PRO-HD to work even rudimentarily are different – it is with the following settings I am getting the undesirable result of a simple/generic remote control and not being able to view Guide listings.

      • Type of device: Other Controllable Device
      • Manufacturer: Microsoft
      • Model: Media Center

       

      Question 1) Is anyone out there using their PRO-HD successfully as a Standalone PVR to control an XBOX 360 as a Windows Media Center Extender and/or suggest what I should do differently to get to my desired result?

       

      Question 2) What is the best way to report a bug to Slingbox to maximize the possibility of a fix for the PRO-HD (as I am desperate to get this to work as it did with my Slingbox Classic)?

        • Re: PRO-HD: Microsoft Media Center Remote Not Working
          alanrichey42 Master
          The “dumbed down” settings I am having to use to get the PRO-HD to work even rudimentarily are different – it is with the following settings I am getting the undesirable result of a simple/generic remote control and not being able to view Guide listings.

          Have you run the Standalone SlingPlayer and checked the Connect > Remote Keys menu option to see if the proper remote is on the list ?

          • Re: PRO-HD: Microsoft Media Center Remote Not Working
            TMTYL

            Are you using your WMC as a full live tv setup? I've got a quad tuner ceton card in my WMC machine. Slingbox doesn't recognize WMC as a device for live TV. Have you found a resolution for this?

             

            Thanks!

            • Re: PRO-HD: Microsoft Media Center Remote Not Working
              byronomo

              I'm not sure if it helps or not but here is what I can offer:

               

              I control my Media Center PC nearly flawlessly via my Slingbox Pro HD.

               

              My understanding is that Media Center PC Remotes are standardized (as in you can buy an off-the-shelf Media Center Remote and have it work with any Media Center PC).  I'm not 100% sure about this, but this is my understanding.

               

              On my SlingPlayer software I selected  an HP Media center PC (the manufacturer of my Media Center PC).  This appears in the SlingPlayer software as "HP Other Controllable Device".

               

              I would sugget that you set up your Media Center as an HP and see if it works.  Probably no downside in trying.

                • Re: PRO-HD: Microsoft Media Center Remote Not Working
                  erempalski

                  Thanks for the HP tip, it as least gets most of the functionality for Windows Media Center, I'm using a loaded PC with Happague and Ceton cards and diskless X-Boxes as Media Extenders.  They work great and boot straight into Windows Media Center, they respond to the std WMC Remotes and now mostly to the SlingBox.

                   

                  BUT, This blows..  Here's why...

                   

                  I have 2 Sling Classics, 1 Solo, and one older Pro.  ALL of these work perfectly with their input selected as Windows Media Center PVR, the Microsoft Media Center Remote GUI looks correct and WORKS perfectly.  Only this new ProHD unit is broken.

                   

                  They have messed up the firmware on this nice $300 device for Media Center as well as ReplayTV (which also works fine on all my other boxes and not on this new ProHD).

                   

                  I thought I had a bad unit, returned it for an exchange, only to verify that Sling messed up the firmware.

                    • Re: PRO-HD: Microsoft Media Center Remote Not Working
                      alanrichey42 Master

                      Here is my first attempt.   Does it operate correctly ?  Is the right skin showing ?  I know a few buttons are missing, that will be fixed in the next version if the rest is OK.

                        • Re: PRO-HD: Microsoft Media Center Remote Not Working
                          erempalski

                          Thanks for your help, great start!

                           

                          It works as you describe.  I placed the files in the PC player SBAV folder, configured the source as Standalone DVR, Brand-Microsoft, Model-Other, Code-V1101.  Interesting, the PowerButton test did not work, but I went ahead and accepted the config to check the other buttons.  The skin was the Microsoft rounded white media center remote, and in the skin the power button works just fine!

                           

                          Now some buttons don't work as you mentioned.  There are some codes that are very useful that I hope can be mapped.  I have them as hex files in my Pronto if it would help any.  Here's what would be great;

                           

                          Currently dead, needing mapping.

                           

                          Green Windows "Start" Button, dead

                          Replay, dead

                          Skip, dead

                          Clear, dead

                          Back, dead

                          Live TV, dead

                           

                          The Red, Green, Blue, Yellow buttons are labeled nicely but are currently either dead or mis-mapped.  Here are my learned hex codes for these;

                           

                          Red - "My Videos" should be this;

                          0000 006D 0020 0000 0066 0023 0010 0012 0010 0012 0010 0023 0010 0023 0032 0023 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0023 0012 0010 0012 0010 0012 0010 0012 0010 0023 0010 0012 0010 0012 0010 0012 0023 0023 0010 0012 0010 0012 0023 0023 0010 0012 0023 0023 0023 0023 0010 0023

                           

                          Green - "My Music" should be this;

                          0000 006D 0000 0021 0066 0023 0010 0012 0010 0012 0010 0023 0010 0023 0032 0023 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0023 0012 0010 0012 0010 0012 0010 0012 0010 0023 0010 0012 0010 0012 0010 0012 0023 0023 0010 0012 0010 0012 0023 0023 0010 0012 0010 0012 0023 0012 0010 0012 0010 0AAB

                           

                          Yellow - "My TV should be this;

                          0000 006D 0000 0021 0066 0023 0010 0012 0010 0012 0010 0023 0010 0023 0032 0023 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0023 0012 0010 0012 0010 0012 0010 0023 0010 0012 0010 0012 0010 0012 0010 0012 0023 0023 0010 0012 0010 0012 0023 0023 0010 0012 0023 0023 0010 0012 0010 0012 0010 0A55

                           

                          Blue - "My Pictures" should be this;

                          0000 006D 0000 0020 0066 0022 0010 0012 0010 0012 0010 0022 0010 0022 0032 0022 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0010 0012 0022 0012 0010 0012 0010 0012 0010 0022 0010 0012 0010 0012 0010 0012 0010 0012 0022 0022 0010 0012 0010 0012 0022 0022 0010 0012 0022 0022 0010 0012 0022 0AAB

                           

                          Thanks again!

                    • Re: PRO-HD: Microsoft Media Center Remote Not Working
                      SweetLew0227

                       

                      Also yesterday while i was watching it lost connection and now it won't connect to my network anymore.

                      I reset it and the network light just blinks for up to a minute then shuts stops and both the power light and network light go off..

                      I dont know what to do.