31 Replies Latest reply: May 24, 2011 10:26 AM by bobbyzee Branched to a new discussion. RSS

    Terrible performance after firmware update

    techextras

      Hi,

       

      We've been running a Slingbox ProHD for about 6 weeks and it's been great. Last week we updated to the latest firmware and ever since have been getting consistently poor performance when streaming video. It does not matter if using the windows Slingplayer, iPod Touch Slingplayer or watch.slingbox.com

       

      We're experiencing 2 video/streaming issues that happen nearly every time we use the slingbox now.

       

      - one problem is a complete freeze up of the stream to the point where we have to logout or log back in again.

       

      - the other issue is "rolling video" where at some random point in the stream, the video cuts off at the bottom of the screen and start to scroll down from the top.

       

      We were so happy with the Slingbox running the "original" firmware that was present when we got the device and couldn't be more unhappy with it since the firmware update.

       

      Any one have any ideas or similar issues?

        • Re: Terrible performance after firmware update
          graham115

          I'm having the same problems. Since remotely updating the Slingbox Software to Firmware 2.1.80, I'm experiencing terribly unreliable performance. I am using watch.slingbox.com (both IE 7 and Firefox) because I'm unable to use Slingplayer for Windows because every time I try to install the Slingplayer software it fails. Although it sounds like Slingplayer has the same problems too.

           

          Before updating to the new Firmware I was able to watch online using Slingbox.com without much trouble, although it would need to be reset fairly frequently from the Slingbox location. However, since the firmware update I can usually watch at most 3 to 5 minutes of content before the player freezes and crashes. The error is "There was an error connecting to your Slingbox. Please try again. Do you want to retry? [Code:W211]" Before the fireware update I could watch full football games (3 to 4 hours) without any trouble or interuption.

           

          Connecting errors are frequent also - including: "Your Slingbox has been disconnected because of a poor internet connection. Try connecting again. Do you want to retry? [Code: W202]"

           

          Now when I get a connection the optimizing is slow at first, then ramps upto full speed, but ultimately freezes up between 2 and 5 minutes later. Also, using the remote also seems to lead to crashes.

           

          After reading these forums, I'm convinced that these problems are new and are caused by the new firmware release. Hoping that Slingmedia will stand behind their expensive products and offer a real solution in the form of a new firmware update that actually works.

            • Re: Terrible performance after firmware update
              Dray

              I'm having the same problem and I keep getting Slingbox Software:warning on my support page and there is no other update available, it would be nice to get some help from slingbox support!!!!

                • Re: Terrible performance after firmware update
                  mikemcd22

                  I am having similar issues.  After I updated the firmware, I got a "password incorrect". while watching from a browser at a remote location.  I entered the password several times before it finally let me in...  the next day (today), I was rejected several times...  I finally logged out of my  account and back in; chose "watch" and was not prompted for a password.   It just played normally.

                   

                  Last night, I wanted to watch the Jets/Pats from my iPhone and I got a very confusing " Invalid Password"  "The password is incorrect, try again?"  followed by an input box and then " Admin Password? [on or off]" and then a "yes or no" option.  I tried every combination I could think of...

                   

                  Today on my phone, I get "Sling Player cannot connect to your Slingbox,  Make sure your phone and Slingbox are connected to the internet and try again"... even though I just connected to it through my browser.

                   

                  Very Frustrating....

                   

                  Mike

              • Re: Terrible performance after firmware update
                jmcclendon

                I have the same problem. I am furious with slingmedia. My slingbox has been fantastic since I bought it last year and it has worked like a charm. Recently I was prompted to upgrade the firmware and after the firmware upgrade this has turned into a nightmare. My connection to the slingbox is disconnected after anyware from 20 - 30 seconds. I called tech support and they will not admit they have a problem with this latest firmware. I asked if I could go back and was told that is not an option.  The only option now is to pay for tech support or go buy a new slingbox. I told tech support don't expect me to shell out anymore money for their product if it's only going to last one year. By the way I have a Slingbox Solo. Lets hope someone will step up and provide a fix for this.

                  • Re: Terrible performance after firmware update
                    mkmscr

                    Quick update on my end. I downloaded old sling player software that allowed me to load any firmware (aka roll back) I wanted onto my slingbox pro hd. So I uninstalled my sling player 2.0 entirely from my laptop, then downloaded the old slingplayer version, then found an old version of slingbox firmware from 4/2010. Loaded the old firmware onto my sling pro hd and it's working fine again with my sling catcher. You can re-download the 2.0 player and ignore the firmware upgrade options or use the web interface. Everything you need can be found on a site called placeshiftingenthusiasts.com. If it wasn't for this site I don't know what I would have done. For the record, I stream from at over 5MBs to a Sling catcher. The HD setting never works right even with my incredible bandwidth stream. The sling pro hd was a waste of money. Anyway, I hope this helps others since Sling won't lift a finger, unless you pay them of course.

                      • Re: Terrible performance after firmware update
                        simonhead666

                        Hey

                        I went to the site you mentioned got the 40 Firmware packages download.. because my firmware is newer,I can't downgrade to an older firmware.. How did you get around this?

                        thanks

                          • Re: Terrible performance after firmware update
                            mkmscr

                            You need to download the old version Sling PLay program, I believe it's called the any Slingplayer, try this link http://placeshiftingenthusiasts.com/downloads-available-here/?did=243


                            This will allow you to connect to your Slingbox and load any firmware onto it.


                            As a side note, I did not download the 40 firmware files, I downloaded one firmware file for my Slingbox Pro HD. It has been working perfect since I did this. 

                            SlingBox ProHd Firmware V1.4.060

                              • Re: Terrible performance after firmware update
                                simonhead666

                                Thanks for your help

                                I actually fixed the issue by re plugging the ethernet cable from my router... Very strange.. but I guess some dust got in the way of the connection..

                                Works great everywhere..

                                I also did notice that the solo is very sensitive to heat.. I once had an issue that it wouldn't connect, I raised it off of the counter (in my cabnet) it was on with a few erasers.. Worked great

                                 

                                thanks again!! I thought I was going to have to get a few IR blasters for my elgato eyetv and use that for viewing!!!

                                • Re: Terrible performance after firmware update
                                  graham115

                                  This whole idea of downgrading to an older firmware may work for some, but am I the only person that thinks this SHOULD NOT be the "solution" to the problem??? As far as I'm concerned, Slingmedia needs to issue a firmware fix that addresses all these issues. I am not able to use Slingplayer for Windows because whenever I try to install is, it says that there is incompatibility with Windows Vista... So instead, I use the Slingbox website - which will just not perform well enough to even use. Either way, my performance is still terrible. Anyone else having this problem with the firmware update from November 2010 (2.1.80)??? I really wished my Slingbox worked again... I'm not paying $30 for tech support which sounds like it won't even help... anyone have any suggestions?

                                    • Re: Terrible performance after firmware update
                                      mikemcd22

                                      I don't know if this will be any help to anyone (I am still ticked off at Slingmedia)...  After having all the same issues reported here and other places, I did install the Bios upgrade AT HOME (on the same network) and then I RESET my box.  Since then, everything seems to be working ok...  The issue with the very unecessarily convuluted password... also seems to go away.

                                    • Re: Terrible performance after firmware update
                                      waynecoop

                                      After you download this program from that site, does it give you instructions on how to downgrade the firmware?  I have downgraded the player to the older version from 2009 when I bought the slingbox, but don't really understand how you downgrade the firmware in the slingbox itself.  When I get home I will download the software you recommended and the version 1.4 file as you said, but can you give me some help as to how to load that into the slingbox.  I don't get home for many days at a time and will not have time to look for this answer once I start trying.  Thanks.

                                  • Re: Terrible performance after firmware update
                                    rburns45

                                    Looks like I am not alone with W202. (My connection and remote locations are fine.)

                                    Everything worked fine at home before my trip. I don't need Slingbox when I am home.

                                    Now what can I do that I am not home?

                                    Can I do any rollbacks while away?

                                    What a joke!

                                    Thanks for any help.

                                • Re: Terrible performance after firmware update
                                  scbryan

                                  I am also having issues, my ipad, slingcatcher, and internet viewing is very choppy and buffers a lot, ALL within my high speed home network

                                  • Re: Terrible performance after firmware update
                                    hib

                                    I'm having terrible connection issues after the update with my pro hd.  My sling catcher or slingbox.com viewing constantly freezes.. as if it is dropping a a connection.

                                    • Re: Terrible performance after firmware update
                                      bobbyzee

                                      Same thing here. I have the extended warranty and they sent me a new slingbox pro hd and I have the same problem. I will call again and see if tech can do anything.

                                        • Re: Terrible performance after firmware update
                                          rburns45

                                          Good luck.

                                          Let me know if anything works.

                                          Thanks

                                            • Re: Terrible performance after firmware update
                                              hib

                                              Given Sling's update speed history, we'll be waiting for a while for a fix, if ever...

                                              • Re: Terrible performance after firmware update
                                                bobbyzee

                                                I called tech support and they will now replace the electrical plug. If that doesn't work "we will take it from there". They deny they have a problem with the pro hd. They acknowledge a problem with the firmware and the solo.

                                                 

                                                Message was edited by: bobbyzee Well, I have now received the new plug and have reset the box. There has been no improvement. I will call them again.

                                                 

                                                Message was edited by: bobbyzee As of 1/9/11 they want me to take the slingbox to a friend's house and see if the problem is my network. Before I do that I am going to upgrade the modem to a docsis 3.0. Will let you know.

                                                 

                                                I upgraded the modem to uploading at 3mps and downloading at 20mps and I still had the problem.

                                                 

                                                I then downgraded the firmware and didn't have the problem, but couldn't use the iphone to stream.

                                                 

                                                I then upgraded the firmware back to the current and took out the component cables in and replaced them with composite cables in, moved the slingbox to its own space on the shelf and elevated the slingbox on some blocks and put a fan behind the slingbox to cool it off. All of this to reduce the heat. Guess what? It has been streaming for hours and I don't have the problem. This whole thing could be heat related. Forget HD streaming on a Mac, it is too hot for component cables.

                                                 

                                                1/13/11 It's not working again. It seems if you reset the box it works for a while. I called and was advised to do a hard reset and to call my isp and confirm there are no restrictions on the uploading of the stream. I have now done a hard reset and confirmed no restrictions on upload. Called again and am being escalated to the next level. They will call me today or tomorrow.

                                                 

                                                Message was edited by: bobbyzee  2/3/11 No one ever called me back even though I was escalated to "Level Three" and I emailed corporate headquarters so I again started reading forums and found someone who suggested that we change the port from 5001 to 1080 on both the AEn and the slingbox. I did it and it has been working for days. We shall see if this lasts.

                                            • Re: Terrible performance after firmware update
                                              Bash Newbie

                                              There is a whole other thread on this very subject that has been ongoing for a long time.  When you reboot your SB, it will play without a problem for a little while, then the intermittent freezing and other problems start.  The only fix we have found is to downgrade the firmware to 1.3.17 (the last one that worked without a problem) and wait to see if Slingmedia fixes it in the firmware.  I agree, this should not be the fix, but it is what it is at this point.

                                                • Re: Terrible performance after firmware update
                                                  BrandonC Novice

                                                  Bash wrote:

                                                   

                                                  There is a whole other thread on this very subject that has been ongoing for a long time.  When you reboot your SB, it will play without a problem for a little while, then the intermittent freezing and other problems start.  The only fix we have found is to downgrade the firmware to 1.3.17 (the last one that worked without a problem) and wait to see if Slingmedia fixes it in the firmware.  I agree, this should not be the fix, but it is what it is at this point.

                                                  It's not easy to downgrade back to an earlier firmware but there are ways to do so. On placeshiftingenthusiasts we have a lot of the older firmware available but I am wondering if it might be better to have specific categories for each Slingbox instead of combining all the firmware into one folder. If you get a chance to check it out I would love your feedback on it.

                                                    • Re: Terrible performance after firmware update
                                                      Bash Newbie

                                                      I think Placeshifting Enthusiasts is a great alternative forum to this one.  I used it to downgrade my firmware last month when I started experiencing the freezup issues with my Pro HD.  I don't recall it being difficult to find the correct firmware, but I do agree with categorizing it so it is easy to find.

                                                    • Re: Terrible performance after firmware update
                                                      bobbyzee

                                                      Check out my post regarding the heat issue.

                                                      • Re: Terrible performance after firmware update
                                                        Bash Newbie

                                                        My Pro HD worked for about two weeks after reupgrading to 2.1.8.  Picture was beautiful, etc., etc.  Yesterday it was out of order again:  freezing, streaming rate up and down, very unwatchable.  My host reset the power (unplugged) and it is working fine again.  There is definitely a problem with buffering or something getting jammed up after awhile that requires it to be rebooted.  SlingMedia: are you listening to this?  This is a definite problem.  Please address soonest, thank you.

                                                          • Re: Terrible performance after firmware update
                                                            popesterb

                                                            I had the same problem, and it was a 2 part fix for me.  I had never thought about the heat issue but after reading this forum I called my Dad to find out where he had put my ProHD and lo and behold, he had it right on top of the PVR / Cable Box.  So he moved it and reset the Sling Box, with immediate improvement, although still not perfect.  The skips still happened, but I'd classify them as skips as opposed to freezes.

                                                             

                                                            Next I followed the advice of the folks over at place shifting enthusiasts and installed the old Sling Player to allow me to roll back the firmware to 1.4.60.  Been working perfectly ever since!!!

                                                             

                                                            Hope this helps out others in the same boat...

                                                             

                                                            Cheers!

                                                        • Re: Terrible performance after firmware update
                                                          ACC1165057

                                                          I reinstalled v 1.4.60  from 2.1.80 for my PRO HD and it resolved all of the throughput issues.

                                                           

                                                          With version 2.1.80 my throughput was running up to 128kb and dropping to 20kb. After reverting, it is back to normal with throughput from 1-2MB.  My only issue is now everytime I load the desktop slingplayer app it displays a message that there is a newer version available, update now or later, which is annoying.

                                                          • Re: Terrible performance after firmware update
                                                            psinc

                                                            Hi techextras,

                                                             

                                                            I was wondering if you found any solution to the "rolling video" that you were experiencing. I've recently run in to the exact same symptoms and while I have pretty good experience with troubleshooting Slingbox problems, the "rolling video" is a new one to me.

                                                            • Re: Terrible performance after firmware update
                                                              simonhead666

                                                              Ok so the the freezing issue is back.

                                                              I'm thinking it's a heat issue because of the iPhone component. (high quality/standard quality stream selection) and something to do with firmware. Either that or the slingbox is cranky with certain modems. Either or, it needs to be fixed...

                                                              Any coders out there that can disable the high quality stream for iPhone could probably fix the freezing issue.

                                                               

                                                              HEY SLING, GET IT TOGETHER!! I need something to do at work!!!

                                                               

                                                               

                                                              • Re: Terrible performance after firmware update
                                                                zahnfee

                                                                I cant believe that after such a long period of time that the firmware issue has not yet been resolved,

                                                                I updated my slingbox to the current version only to find that the slingbox would freeze all the time and

                                                                the stream would fluxuate going from 990kbps to 190kbps.

                                                                 

                                                                The only way I could fix this issue was as mentioned, downgrade the software to 1.4.60 and

                                                                straight away a nice steady stream of 1100kbps and hasnt frozen yet.

                                                                Why is slingmedia not addressing these issues, this isnt a one off problem!!!

                                                                 

                                                                DO SOMETHING ABOUT THIS SLINGMEDIA!!!!!!!!!!