1 Reply Latest reply: Oct 17, 2010 2:35 AM by sjjs RSS

    Slingplayer connects remotely, but does not stream video

    sjjs

      I have a SlingBox Solo sitting behind an AT&T DSL 2WIRE router.   It works fine over my home network,  from my office, from Costa Rica (Slingbox tech) and from a couple of other locations.   However, it does not work when my daughter tries to connect through her FIOS link in her apartment.  It successfully connects, but then sits in the optimizing phase for a couple of minutes w/o every displaying any video/audio.   The connection then drops.

      All of the above experiments were tried running SlingPlayer (and via the browser plugin) on a MacBook running 10.6.5 (except for the Costa RIca connection, not sure about that).
      I've connected to her FIOS router (MacOS X remote desktop is a lifesaver) and enabled full error logging.   Here are the error messages of interest occurring on packets targeting port 5001.
      Blocked-Fragmented packet
      Blocked-Default policy
      Blocked-Illegal options
      I've talked to my networking buddies, and they believe it's some kind of fragmentation issue due to a mismatch is that the FIOS router can't/won't handle, but that's really just a guess since we really don't have a way to collect a packet trace.
      I've tried turning off the firewall, and putting my daughter's computer into the DMZ zone (totally outside the firewall)... neither of these had any effect.
      I've also tried adjusting the uplink mtu size in the 2WIRE router... I've set it to the maximum size  (1492 for PPOE connection) and also a couple of smaller sizes (1280 and 1480) to see if that might change the fragmentation.  Again, these changes had no effect.
      We also tried from her roommate's Windows box and saw the same behavior... connected, but wouldn't stream.
      Has anyone seen anything like this, and if so, what was the resolution?
      Thanks in advance

       

      Message was edited by: sjjs I've also tried switching from port 5001 to port 443 and then port 80.   It still failed to stream at my daughter's apartment.  It continued to work just fine from my office location with both alternate port configurations.

        • Re: Slingplayer connects remotely, but does not stream video
          sjjs

          Turns out it was an mtu issue caused by the combination of the 2WIRE router, the FIOS router and the sling box.  For some reason, the end to end mtu size negotiation wasn't taking place correctly.  A sling box tech was able to remotely force the mtu size the slingbox solo was using to 1452 bytes.  The player is now able to stream properly at the problematic location.