41 Replies Latest reply: Apr 25, 2017 7:40 PM by captron06 RSS

    10.12.x Sierra     v.9 (and above)     v.47 (and above)     v.52 (and above)

    rocket625 Newbie

      i have 10.12 with safari 10. and it says anananananna not compatible with that browser.