3 Replies Latest reply: Sep 21, 2010 1:52 PM by miamiparis RSS

    Would it work with a Metropcs Blackberry?

    miamiparis

      My phone company is Metropcs. Is there a Metropcs phone that would work with Slingplayer mobile?

      You can see the list of all NEW Metropcs  phones at http://www.metropcs.com/shop/phonelist.aspx

      But there are also older model of metropcs phones which are not listed.

      On the new list, there is the Blackberry Curve 8530, would it work with Slingplayer?

        • Re: Would it work with a Metropcs Blackberry?
          dbsguy Apprentice

          It will work fine on the blackberry model you listed. However as I indicated on another thread I can't view the phone list on the site you posted as it's askign for a zip code and mines not in their database based on location....

            • Re: Would it work with a Metropcs Blackberry?
              miamiparis

              Thanks. Can you please also tell me if the Blackberry 8330 from Metropcs would work also?

                • Re: Would it work with a Metropcs Blackberry?
                  dbsguy Apprentice

                  The Blackberry Curve 8530 or the Samsung Code - Smartphone which runs windows mobile.

                   

                  The 8330 doesn't play well with slingplayer....

                   

                  These are the "Officially Supported" Blackberry models and the specs required:

                  Recommended BlackBerry smartphones

                  • BlackBerry Bold 9700
                  • BlackBerry Bold 9000
                  • BlackBerry Curve 8900
                  • BlackBerry 8820
                  • BlackBerry Curve 8320
                  • BlackBerry Curve 8320
                  • BlackBerry Pearl Flip 8220
                  • BlackBerry Pearl 8120
                  • BlackBerry Curve 8350i

                  BlackBerry smartphone requirements

                  • A supported BlackBerry smartphone with 3G wireless service and/or Wi-Fi Internet connectivity, as well as the following minimum device software versions. (To check your BlackBerry device software version, select Options from your home screen, then select About. Third line shows the device software version installed.)
                    • Bold 9700 – minimum 5.0.0.0 and above
                    • Bold 9000 – minimum 4.6.0.0 and above; optimal at 4.6.0.167 and above
                    • 8900 – minimum 4.6.1.0 and above; optimal at 4.6.1.114 and above
                    • 8820 – minimum 4.5.0.0 and above; optimal at 4.5.0.110 and above
                    • 8350i – minimum 4.6.1.0 and above; optimal at 4.6.1.83 and above
                    • 8320 – minimum 4.5.0.0 and above; optimal at 4.5.0.81 and above
                    • 8220 – minimum 4.6.0.0; optimal at 4.6.0.180 and above
                    • 8120 – minimum 4.5.0.0; optimal at 4.5.0.110 and above

                    • Network download speed of 120 Kbps (or higher)
                    • 2.5 MB free memory on device to install