2 Replies Latest reply: Dec 13, 2016 9:45 AM by SlingSupportMagdalena RSS

    Browser Compatibility

    rock656

      When I login to watch Slingbox I'm getting an error that says my browser is not compatible with the Slinplayer Plugin. When I go to the link provided which lists comparable browsers it shows my browser should work. Tried Safari 10.0, Firfeox 48.0.1, and Google Chrome 53.0.2785.116 (64-bit). Anyone know of a fix?