1 Reply Latest reply: Aug 16, 2016 11:12 PM by christopherdownes RSS

    Cant install Slingbox using  Firefox 47 on Win 10.

    pobjoykhall

      using Firefox 47 with Win 10, each time I try to install Sling-box I get "plug in is corrupt". Same on two different machines. Tried Chrome & received similar result. I  have tried 'about:config'  etc and that didn't work either.