11 Replies Latest reply: Mar 30, 2016 1:02 PM by kleerh2o RSS

    newwatch.slingbox.com now says Firefox not supported?

    Holz75

      Hey everyone.  I recently got a new Windows 10 PC and downloaded Firefox 44.0.2.  I was able to download the Slingplayer Plug-In and watch normally, but now, I'm all of the sudden getting this warning:

       

      "We're sorry, but your web browser, operating system, or the combination of both is not currently supported by the Slingplayer plug-in."

       

      Has anyone else gotten this?  I'm not sure why it was working before, and now it's not.

       

      Thanks!