1 Reply Latest reply: Jun 6, 2011 12:31 PM by Josebrenes RSS

    Slinglink Turbo 4-port stopped working after two years continuous usage

    apiskur

      Hey guys,

       

      I'm not sure what is going on here but I am very upset.  Three days ago my Slinglink mysteriously stopped functioning.  The problem is, it doesn't seem to think it has.  All the lights are still active on both sides of the connection and there are plenty of blinking lights indicating network activity.  Turning off and on my Slingbox and my Slingcatcher make the lights go off and on on the 4-port side but neither one can grab an IP address from my router. I have several other things plugged into my router, both wired and wireless and my internet connection is working fine.  I even plugged both units into the same outlet in the room with my router and they still won't behave.  What in the world is going on here?  Also, I can' seem to find the warranty on these things, but chances are it is only a year warranty (if that).  I have both units plugged into bare outlets with no power strips inline or on the other plug on the outlet.  I've tried powering off an on both Sling units and even some game systems that I tried plugging into the Slinglinks.  Still no joy.  I've been running these things for a couple of years now (or nearly so) and they were fine right up until they stopped working.  Any suggestions?