4 Replies Latest reply: Nov 17, 2012 12:52 PM by onurarpacioglu RSS

    Problems with dual monitor setup

    tgreenstein

      I'm running Slingplayer 2.0 under Windows 7.  I have two monitors: one through DVI running at its native resolution (1920x?); the other is VGA at 1024x768.  Slingplayer works fine on the DVI-based monitor, but when I move the window to the smaller monitor I see the entire Slingplayer frame but the video is only the rightmost 20% of the screen.

       

      I assume this has something to do with starting the app on a screen with higher resolution, then moving it to the lower-resolution screen.  Can anyone suggest a solution?

       

      TIA.

        • Re: Problems with dual monitor setup
          eferz Expert

          The problem is how the the graphic card drivers interact with the Window's graphic subsystem.  Probably the best way to work around it, is to keep the window in the small screen.  Slingplayer will save the window placement, so it will reopen from the last place it was closed.  Otherwise, maybe try setting the smaller screen as the primary display.

            • Re: Problems with dual monitor setup
              tgreenstein

              That's what I figured, and it was one of the first things I tried.  It doesn't make any difference if I start Slingplayer on the DVI monitor and drag it over to the VGA, or if I start it on the VGA screen.  I get sound o.k. but the only the rightmost 20% of the display area has video.

            • Re: Problems with dual monitor setup
              tosh30

              I just installed and setup the player on my system, and I have the same issue.  One monitor works, the other is only 50% of the original viewing area.  Is there any solution?

              • Re: Problems with dual monitor setup
                onurarpacioglu

                Hello all,

                 

                My PC has both an integrated graphics card and a seperate one (NVIDIA). I ran into the same problem and found the following solution:

                 

                Instead of running the slingplayer directly from its shortcut, right click on it and select "Run with Graphics Processor"->"High Performance NVIDIA processor"

                 

                To make this setting permanent, so that you can run Slingplayer directly from its shortcut, you can select "Run with Graphics Processor"->"Change default graphics processor" and then in Program settings, select Slingplayer.exe from "C:\Program Files (x86)\Sling Media\SlingPlayer" in Step 1 and select "High Performance NVIDIA processor" in Step 2. After completing these and closing this confiugration window, you can now directly run Slingplayer from its shortcut without any display issues on both monitors.

                 

                Onur