7 Replies Latest reply: Dec 31, 2015 6:26 PM by ACC5927436 RSS

    Cannot Download New Firefox SlingPlayer Web Plug-in

    GailOwens

      When I try to download the new Firefox SlingPlayer Web Plug-in, it says "the add-on downloaded from this site could not be installed because it appears to be corrupt".  I followed the instructions and Ive tried just about everything I can think of.  I looked and I do not have any plug-in for the SlingPlayer in my list of Firefox addins.  I restarted Firefox.  I restarted my computer. I made sure Firefox was the most recent update.  My slingbox works on Chrome (but Id much rather use Firefox).

       

      Can someone help me out here !?