29 Replies Latest reply: Oct 11, 2015 2:42 PM by Maxcats RSS

    Slingplayer app channel change problems with WD TV Media Player!!

    v1per
    Visibility: Open to anyone

      Hi,

       

      I recently (in the last week or so) bought this WD TV Media Player from Amazon specifically for the Slingplayer functionality to connect to my Slingbox PRO-HD and am having some problems with it.

       

      The biggest one is that I cannot change channels, not with the remote, not any how.

      Basically exactly the same problem as in this thread on the WDD forum which doesn't have a solution.


      I have a SlingCatcher in another room at home which works fine. I also have no similar problems using two phones.

      I've checked the Sling website incase it's firmware on the Sling hardware which needed to be updated for the WD TV - nope, according to this > http://support-worldwide.slingbox.com/get/KB-1000278.html < I'm on the latest, 2.1.420. So I don't believe this is Sling hardware related.


      According to this article > http://www.slingbox.com/en-gb/Support/KB/KB-2000463.aspx < I should be able to just use the WD remote numeric buttons to change channels but alas nothing happens. Literally nothing.
      Infact none of the remote buttons do anything except the colour buttons which bring up the menu.

       

      And. When I bring up the menu I notice that [GUIDE] button is greyed out (see below) which seems odd.

       

      20150913_140946.jpg

       

      This led me to think maybe I have old firmware on the WD hardware (you never know when the item was built from when it shipped). So I had a look into that.

       

      According to this site > http://www.wdc.com/wdproducts/updates/?family=wdfwdtv_g2 < the latest firmware for the WD TV Media is 1.02.17. Checked my hardware from the [About] page and yup, 1.02.17 - same firmware.
      I went ahead and downloaded this firmware from the page anyway just to see if it was slightly different - extracted the ZIP to the root of a USB - plugged the USB in - it complied - and nada - no alerts, so seems to me the WD TV Media player is up to date.

       

      I tested the remote keys - they are fine - checked by setting a numeric password which works. So the remote is fine from what I can tell.

       

      So now I'm at a loss.


      If anyone can hep - I'd be very grateful or I'll probably have to send the device back as it's pretty useless if I can't change the channel!

       

      Thanks