6 Replies Latest reply: Jul 8, 2010 1:11 PM by Dana RSS

    Upgraded Firmware to 1.4.20, video quality is horrible!

    xr4ti

      I am using the SlingPlayer for Windows 7 Version 2.0.191

       

       

      I own a Slingbox Pro, and recently upgraded the firmware to 1.4.20 I am now experiencing extremely poor video quality, the picture rolls, horizontally and vertically, I get a split screen where half the picture is cut off, a bar on the bottom of the screen and poor color saturation.

       

      This problem exists on all of my devices HP Laptop, MacBook Pro, iPhone, iPad and on the http://www.watch.slingbox.com/watch/sling_player website.

       

      Therefore, I believe there is a problem with the newest version of the firmware that was released in June of 2010.

       

      My internet provider is Comcast and I am getting the 16MB download 2MB upload package with their Powerboost service. I contacted Comcast to verify this information.

       

      Trouble shooting steps that I've taken so far.

       

      1. Contacted my Internet provider "Comcast" and checked and verified my Internet connection and speed.

       

      2. Reset the Slingbox Pro by holding in the reset button to return device to factory defaults and re-setup the Slingbox Pro.

       

      3. The Slingbox if viewable on my HP Windows Laptop running Windows 7

       

      4. MacBook Pro running MACOS 10.6.4, iPhone running iOS3, and iOS4, iPad running iOS3 and at www.watch.Slingbox.com

       

      After spending several hours trying to fix this problem by researching the Internet and the Slingbox Forum site I have come to the conclusion that there is a problem with the last version of the firmware for the Slingbox Pro. There is no way to reinstall the firmware or downgrade to the last "working" version. My Slingbox is out of warranty however, was working just perfectly until I upgraded to the latest firmware. Therefore, contacting customer support is $50 per incident or I can upgrade to a new device and my cost with at $59 dollar credit for being a "loyal" customer.

       

      The problem is that I should not have to pay $50 to talk to customer support for a problem that SlingMedia caused by releasing a firmware update that clearly caused this issue. I also will not fork over another $250 for a new unit when the one I had worked perfectly until the firmware update.

       

      I will say this for Slingbox when you're under the 90 warranties they have excellent customer service but on day 91 they could care less about their customers. I had bragged to companies at how great Slingbox customer support was in the past until my warranty ran out and I was disowned. I called to ask how to set up remote viewing after I upgraded my computer and was told it would cost me $50 bucks to walk me through it or even send me an email describing the process.

       

      To be honest I am not expecting any help from SlingMedia on this issue but I am willing to give them an opportunity to prove me wrong.

       

      All I want is what I paid for a working Slingbox or a fix to return my current SlingBox to working condition via software fix, firmware upgrade or downgrade. I did not cause this problem; installing an official firmware upgrade from SlingMedia caused it.

       

      In the trouble shooting notes SlingMedia suggested that I reinstall the firmware, I have looked all over this site and have not found any way to do preform that procedure, the firmware was under downloads but has since been removed. So, its not like I have not tried everything I could to resolve this issue on my own.

       

      I would appreciate any help on this matter I watch my Slingbox daily and have really enjoyed the service until this happened.

       

      Thank you for your time and concern,

        • Re: Upgraded Firmware to 1.4.20, video quality is horrible!
          tbelda

          Thank you for posting this.   I have had the same exact trouble making my Sling Pro Unusable for the past 3 months!   My scenario is exactly like yours only I am with Charter Communications Cable Service...

          • Re: Upgraded Firmware to 1.4.20, video quality is horrible!
            robo

            Same here worked great even bought the ipod app then boom the  worst pic is the worst come on guys help us out here.....your killing us

              • Re: Upgraded Firmware to 1.4.20, video quality is horrible!
                eferz Expert

                For those of you having this problem, I'd recommend in seeing if there's an update for the Slingplayer that you are using.  It is possible that they altered the SlingStream in a way that your current Slingplayer client might not be able to decrypt/decode it properly.  If it doesn't appear to be an update, you can try uninstalling the software and download a fresh copy from (http://support.slingbox.com/go/downloads).

                 

                Unfortuantely, because of Sling Media's "infinite wisdom" they not provide us with the detailed changes associated with their updates.  They merely provide an an annoying update queue which you can't quiesce.  So, it sometimes it feels like we're playing Russian Roulette when we download and apply them to our Slingbox.

                 

                I know at least two or three people on this forum with Slingbox Pro the firmware 1.4.20 update whom aren't not experiencing problems.  Actually one of them had picture quality issues but with extensive troubleshooting he figured out the problem had to do with personal settings on his computer.  He's posts are here (http://placeshiftingenthusiasts.com/forum/slingbox-hardware/slingbox-pro-best-firmwareslingplayer-version) and here here (https://community.sling.com/message/8542#8542).

                 

                If you ensured that you have the most updated Slingplayer client then maybe its specifc to the firmware.  Since you guys are the first I've heard with these specific symptoms, I can only guess that this is a localized problem.  All things being equal; Slingbox are mass manufacturerd and we all download updates from the same repository.  So, I would hazard a guess that somewhere during the update process certain files, bits, or bytes weren't recorded properly.  Of course, this is a shame to Sling's deployment team for not employing better CRC error checking routines for the update process.

                 

                Since I've never rollback the firmware myself, I can't recommend that you guys do it.  However, I can provide you with the links to the resouces necessary to accomplish it at your own risk.

                 

                 

                Good Luck!

                  • Re: Upgraded Firmware to 1.4.20, video quality is horrible!
                    xr4ti

                    I appreciate your comments however, I am not having Issues with one device, its across all of them including Windows 7 (areo theme), Mac OSX 10.6.4, iPhone, iPad and the SlingPlayer website.

                     

                    I just contacted Sling Support in regard to this issue they will only help me if I pay the $29.99 per incident fee and they said that does not guarantee a fix to the problem, just that they will open up a ticket and attempt to trouble shoot, I explained that I did all of the trouble shooting that I am able to do as I listed in my earlier post. They said well we can go through it and try it again, I asked if that does not resolve the issue then what? The representative said well then I don't know...

                     

                    If it was $29.99 and a guaranteed fix I would have considered it even though the problem started after I upgraded the firmware to 1.4.20. However, I am not going to pay $29.99 just for the heck of it, thats not going to happen.

                     

                    It's too bad I really enjoyed the Slingbox while it worked, I have it for the iPhone and was looking forward to the iPad version however, I can't continue to support a company that doesn't support their customers.

                     

                    If anyone has any suggestions please feel free to let me know I would love the help.

                     

                     

                    Thank you.

                      • Re: Upgraded Firmware to 1.4.20, video quality is horrible!
                        eferz Expert

                        xr4ti wrote:

                         

                        I appreciate your comments however, I am not having Issues with one device, its across all of them including Windows 7 (areo theme), Mac OSX 10.6.4, iPhone, iPad and the SlingPlayer website.

                         

                        If anyone has any suggestions please feel free to let me know I would love the help.

                         

                         

                        The first part of my response was meant for the "me toos" that coat tailed off your original message.  They were not as elaborative in their own experiences, so I cannot be sure that their troubleshooting methodology was as complete as yours.  Beside since this seems to be more like a "one off condition" its only prudent to check for updates of the client software.

                         

                        The bottom-half was directed to you, since you eluded the desire to rollback the firmware.

                         

                        I just contacted Sling Support in regard to this issue they will only help me if I pay the $29.99 per incident fee and they said that does not guarantee a fix to the problem, just that they will open up a ticket and attempt to trouble shoot, I explained that I did all of the trouble shooting that I am able to do as I listed in my earlier post. They said well we can go through it and try it again, I asked if that does not resolve the issue then what? The representative said well then I don't know...

                         

                        If it was $29.99 and a guaranteed fix I would have considered it even though the problem started after I upgraded the firmware to 1.4.20. However, I am not going to pay $29.99 just for the heck of it, thats not going to happen.

                         

                        When I call customer support, I use a form of social engineering to get exactly what I want. First, I try to establish a rapport with the person on the other end of the line.  Usually by getting their name (full name if possible) then I try to explain the issue in away to get them to be empathetic to my problems.

                         

                        Try not to use "you" when referring to the company, but instead try use the company name.  Most often the person answering the phone are paid low wages, so its pretty easy to make them feel like you two are fighting against the corporate machine.   I do that by trying to hone in on how they respond, what they say, and how they speak.  That way, you're not dealing with a customer service representative who is trained to act sympathetic but a person who is empathetic to your situation.  After all, its easier to win a battle if there's someone behind the lines doing the fighting for you.

                         

                        If it seems that they can't help me, then I politely ask for their immediate supervisor.  Make sure you explain that you understand their limit in authority but that you really need help from someone empowered to help in your unique situation. Don't let them pull the "second  voice" technique on you, since two half  wits don't make it whole.  Make  sure the next person you speak to is someone with  authority.  Remember every business has organizational tree from the CEO all the way down to the CSR, so don't be afraid to climb the ladder to get what you need.

                         

                        Once you get to a person of authority, make sure that you repeat the names of whom you talked but couldn't help.  This gives them the impression that you're writting things down and are willing to exercise your full legal rights (without having to say it, of course).  Again, more social engineering.

                         

                        Explain to them that you are willing to spend the $29.99 to troubleshoot the issue in case there was something that you might have missed.  However, if the root cause indicates a problem with the Slingbox, then you need the company to take the onus of responsibility.  Since the updated was deployed without proper techniques to avoid this problem.

                  • Re: Upgraded Firmware to 1.4.20, video quality is horrible!
                    Expert

                    xr4ti - you've done a great job of providing details, so forgive me if I missed something, but could you provide us additional details about the SOURCES you have connected to your PRO? What is attached, using what cabling, etc.?

                     

                    Any info along those lines might help us to provide the appropriate troubleshooting steps... Thanks!