4 Replies Latest reply: Nov 1, 2014 11:20 PM by karog RSS

    I hate forced slingplayer plug-in upgrades

    karog Newbie

      I am still running OSX 10.6.8. My hardware will not support newer versions and my current setup handles all of my needs just fine. Well, except sling now.

       

      I just tried using my slingbox pro hd after not using it for a few months. I discovered I cannot use it because my OS is now not supported. It is fine that newer plug-ins do not support old OS's but why can't I continue to use the older plug-in that worked just fine? There is no good reason to force me to a plug-in that will not run.

       

      I will never buy another sling product and will advise against it to everyone who asks me about it. This is ridiculous.