1 Reply Latest reply: Sep 27, 2014 7:46 PM by ferguspa RSS

    I don't have OS 10.8.3.  How can I watch?

    gdmatthews

      Slingbox won't let me decline the new SlingPlayer plug-in.  When I click the "I do not accept" button on the terms and conditions page, the page refreshes to the exact same page, asking me to accept the terms and conditions of service.  If I "accept," it takes me to a page to download the plug-in but specifies that I must have OS 10.8.3, which I don't.  How can I continue watching with 10.6.8?