10 Replies Latest reply: Nov 26, 2010 5:24 PM by Sling922 RSS

    "waiting for install to complete" - never completes

    patsub1

      I have tried installing and uninstalling the plug-in a few times to be able to watch. I get the message that the sling box plug-in has been sucessfully installed and then i get the message that i should restart my browser. After doing that, when i click on "yes" for having a already set up sling box, I get the message "waiting for install to complete" and then it returns to the same window, as though I didnt click yes. This is driving me nuts. Any ideas?

        • Re: "waiting for install to complete" - never completes
          eferz Expert

          Try rebooting your computer and the going to this link (http://watch.slingbox.com/watch/sling_player)

          • Re: "waiting for install to complete" - never completes
            Bryanod Novice

            You have some setting or software blocking it.  Check antispyware programs and internet security settings

            • Re: "waiting for install to complete" - never completes
              scjimf

              I'm getting the same thing.  I've rebooted, reinstalled firefox, reset the Slingbox, no firewall, and still the same thing.  The Slingbox was built with PC in mind and not a MAC.  I'm going to put another hour or two into this, and then it's going back to BestBuy.

              • Re: "waiting for install to complete" - never completes
                Winchdude

                I too have had the same problem and nothing I tried seemed to work.  As I posted on another forum on the subject, as a last resort I finally upgraded my Firefox software (on a Mac) to version 3.6.10 and tried again.  Worked like a charm.  No more looping and everything works just fine.

                Hope this helps.

                  • Re: "waiting for install to complete" - never completes
                    delthibodeaux

                    I always used Firefox because I didn't want to make my Safari browser 32 bit.  Well this morning when I started firefox to Watch, it prompted me to down load the new plug in.  I did, and had problems, first it said completed successfully, quit and restart the browser.  I did this and it again prompted me to upgrade the watch plugin. I did this for a couple of iterations, gave up and restarted my iMac.  After this I restarted my iMac, started the firefox browser and it says "checking your account" so I waited and waited and waited.  I gave up closed the browser.  Then for the heck of it, I started Safara and voila!  I am able to Watch from Safari, no questions about 32 bit etc.  It just worked!  Then I closed that off and started my Firefox browser, this time it also worked!!!  Perfectly! 

                     

                    What all did they change in this update?  I don't know how to determine the version number of this update on September 19, 2010.

                      • Re: "waiting for install to complete" - never completes
                        Winchdude

                        del

                         

                        Glad that it is working for you now.  I too had to do a couple of restarts, close and re-open, and anything else I could think of before it decided to work.

                        I don't have a clue as to what was changed in this version over the last one.  I did update the Flash software too when prompted.

                         

                        To find out what version history you have, when in Firefox, go up to the top of the screen and click on Firefox and come down to "Preferences".  When in the preferences pane, click on "Advanced" then click on "Update".  Once in that pane, click on "Show Update History".  This will give you the updates dates and version numbers for the updates.

                         

                        If you just want to know what version fo the software your using, instead of going through all the above, just click on Firefox and then on "About Morzilla Firefox".  this will give you the version.

                         

                        Good luck

                    • Re: "waiting for install to complete" - never completes
                      Sling922

                      I have spent my Black Friday delving into the Black Art of SlingPlayer Plug-In installation. My complete story started with this thread trying to get the plugin to install. To make this happen I created a new user and got the plug-in to install but not work correctly i.e. "no audio". I then copied the plug-in to my original user and changed the rights to the original user and put it in the correct directory "/<user>/Library/Internet Plug-Ins". I can now get video but alas I have no audio. I know the Pro-HD is installed correctly as my SPM on my iPhone works correctly, IE on my Windows machine works and finally Safari on my iMac works. What does not work is Safari or Firefox on my MacBook Pro. How do I debug why the auido playback is not working? Would "Flip4Mac" or "Silverlight" interfere? I have tried with both uninstalled and it did not help.