3 Replies Latest reply: Feb 15, 2015 12:22 AM by ajenn202 RSS

    Firefox plug in won't work

    superclio

      Is anyone else having issues watching on Firefox? I can watch on Safari or Chrome, but every time I go to FF it tells me I need the new plug in, so I download it, install it, then restart FF and go to Watch and it tells me. . . I need the new plug in. I can't get past this page even though I've installed the plug in. I've never had this before and have been watching on FF for a few years now. Any ideas?

       

      I'm on Mac OSX, FF 27.