10 Replies Latest reply: Oct 20, 2013 5:54 AM by OvCollyer RSS

    Can I turn off "optimizing"? It makes the video jittery!

    Dryslot

      I just built a very fast Windows 8 computer using the ASUS Z87-Pro board with the fastest Haswell i7-4770K cpu overclocked to 4.2Ghz which includes the onboard video processor as well. The motherboard has wi-fi built in and I am connected to my network using the 802.11n standard on a 5Ghz connection.

       

      My slingbox 350 is connected to my Netgear N900 (WNDR4500) gigabit router via ethernet.   My slingbox interface on my PC is reporting a streaming bandwidth of over 8Mbps (content dependent) which is obviously outstanding, and as expected the picture is fantastic.


      Here's my problem: 

       

      Under Advanced Settings, when I have the box checked to "Enable Hardware Acceleration", the picture becomes jittery (as warned about in your own manuals) every time I do anything with the programming (start playing a channel, change the channel, look at the guide, etc.) for about 30 to 45 seconds while slingbox is "optimizing" the streaming.  However, once it locks in, the picture is razor sharp, truly outstanding.  But the jittery video gets really annoying when you are frequently interfacing with the video programming.

       

      Now, when you uncheck the "Enable Hardware Acceleration" option, all those problems disappear.  But the picture is a little softer, I presume since it can no longer take advantage of the processor's video chip.

       

      I'd like to leverage my hardware! Is there any way I can turn off the optimization feature of slingbox and avoid the hassle every time of watching jittery video?

       

      Thanks for your help. Other than that, this has been a near-perfect experience.  Keep up the good work!

       

      Eric

        • Re: Can I turn off "optimizing"? It makes the video jittery!
          kentauta Newbie

          I have the same problem.

           

          I have a couple of slingbox 350's on the same LAN (wired connection for both slingbox and PCs).  All 5 PCs I have tried show the same problem with hardware acceleration enabled.  The jitter goes away when I switch between the full screen and windowed modes a few times.  However, each time I do something like changing the channel, the video goes jittery again and I have to do the windowed & full screen cycling. I have had this problem since I purhchased the slingboxes.  I hope Slingmedia at least acknowledges this problem.

            • Re: Can I turn off "optimizing"? It makes the video jittery!
              OvCollyer Apprentice

              I have a theory about this - if you look at the stats window you will see that each time you do the full screen/windowed switch the 'precharge' (which is the length of the buffered video) jumps up and when you hit 4s or more so does the 'play speed'. Once you've done it a few times the precharge will hit the target of 5 seconds and the play speed will be 100 and at this point it plays smoothly.

               

              The jitter occurs when the play speed is below 100 (possibly below 95 for the worst of the jitter). Essentially what happens when you first connect the stream, or when you issue a remote command, is that the stream starts immediately but the video and audio only play at 90% speed. By doing this it means the video and audio buffer can gradually build up, until it reaches 5s at which point the play speed goes to 100 and the video plays normally. The alternative would have been to simply wait for 5s to buffer the video but this would then add an extra 5s to the time taken for any remote commands, which is why Sling have implemented it like this instead.

               

              Now what seems to happen when you switch to or from full screen in hardware accelerated mode is that it rewinds the 'play' position of the video by a second or two; you can tell it does this as you should find it repeats the same couple of seconds video and audio again each time you switch. If you do this 2-3 times you gain the target 5s video and audio buffer much more quickly than if you had waited for it to optimize by itself and so the play speed jumps to 100 more quickly and from then on things play smoothly.

               

              So the bug Sling seem to have here is that when the plugin asks the video to play at 90% of normal speed it doesn't work very well with hardware video acceleration, at least for the video cards of the users posting here (mine is Intel HD Graphics 4000 by the way). In addition, in my own experience, it is only a real issue with a 60fps/60Hz source. I've found it can take anything up to a minute to stabilise and reach the target 5s buffer and 100% play speed, during which time the stream frequently stops completely or speeds up and slows down.

            • Re: Can I turn off "optimizing"? It makes the video jittery!
              anthony.sling Apprentice

              Hey  Dryslot,

               

                   Thank you for posting on our forums website! I can understand how having intermittent video can cause some frustration. The SlingPlayer automaticall optimizing to get the best quality picture according to your network speeds. The SlingPlayer video may be jittery and intermittent at first, but it will clear out after a moment.

                   In order to stop the Slingbox website from automatically optimize the video, you would need to go into the Encoding tab under Settings in the SlingPlayer options menu and turn off the automatic optimizing setting under Local Access and Internet Access.

               

              This article below explains how to set the SlingPlayer to optimize to a specific resolution.

               

               

              You could also go to the link below to help optimize the video at a remote location, or at the home location.

               

               

              If you have any other questions concerning this issue, feel free to respond back or give us a call at 1-877-467-5464. We are open seven days a week, between the hours of 10:00am to 10:00pm EST.

               

              Best Regards,

              The Sling Media Moderation Team

                • Re: Can I turn off "optimizing"? It makes the video jittery!
                  Dryslot

                  Thanks for your reply.  Unfortunately it led to nowhere, unless I'm utterly blind.

                   

                  You mentioned the "encoding" tab under settings.  I don't see that, in fact I don't see any tabs.  But I am presented with choices to click on, they are:

                   

                  Location

                  TV Service

                  Configure Input

                  Add/Remove Guests

                  On Login

                  Advanced Settings

                   

                  I have scoured each one of these choices 10 times, and still can't find an encoding tab.  I attached a screen shot as well.  Thanks, please reply and let me know how I'm missing this.  Again, I'm on the Slingox 350.

                • Re: Can I turn off "optimizing"? It makes the video jittery!
                  OvCollyer Apprentice

                  My experience:

                   

                  - Jitter and freezing during optimizing is significantly worse when the source is 60Hz, eg US 1080i/30 or 720p60. With a Europran source (1080i/25 or 720p50) the optimizing process isn't anywhere near as intrusive, taking the form of a few glitches but never the prolonged (several second) freezing I see with US sources. This is tested on the same computer. After optimizing the video is great unless bandwidth drops temporarily and then similar symptoms appear as it recovers.

                   

                  - Machine spec comes into it. I'm not sure if a faster graphics card or a faster processor helps but the difference in how bad this issue is varies from an Intel i3/HD graphics 4000 (happens a lot) to an Intel i7\HD graphics 4000+NVidia GT650M. The latter doesn't suffer as much, although it's still not as smooth as with European source

                   

                  - Tying in with the above point, you can reduce the issue by setting your display to a lower resolution. Presumably this reduces the load on the CPU/GPU if less data has to be thrown around but if I view the same 1080i/30 source with my resolution set to 1280 x 720 it doesn't glitch as badly as when my desktop is set to 1920 x 1080.

                   

                  My understanding of the Optimization feature is that it enables the stream to start more quickly but during the first few seconds it plays at only 90% of normal speed in order to allow a 5 second buffer to build up. Maybe something about this process doesn't agree with the way the video decoding gets hardware accelerated.

                   

                  • Re: Can I turn off "optimizing"? It makes the video jittery!
                    OvCollyer Apprentice

                    So are there any plans to fix the broken 'Optimizing' stage when the source is 30/60fps?

                     

                    The same PC doesn't have this problem when the source is 25/50fps. Problem seems to reduce the higher spec the machine, but I believe an Intel i3 with HD graphics 4000 and 8GB of dual channel RAM is within the minimum specs and thus this should be fixed since it greatly detracts from the viewing experience as essentially whenever you issue a command, or the buffer drops below 5s and it has to play the video at lower speed temporarily, you get this freezing problem for anything up to a minute afterwards.