16 Replies Latest reply: Dec 19, 2010 1:41 PM by rockalittle RSS

    connecting to network

    miamiben

      I can only connect to my slingbox solo  when I am directly connected to my laptop.  when I try to manually adjust the network settings to my network is where I think I am messing up.  what should my settings be for my network?   My router's IP is 172.16.0.1, subnetmask for the internet is 255.255.255.0, subnet masket for the router is 255.255.0.0 default gateway is 192.168.2.1, what settings should I use for port, subnet mask etc..?   

        • Re: connecting to network
          ArizonaSackbut Apprentice

          Hi Miamiben,

           

           

          The quick answers are:

           

          - The Slingbox uses port 5001 by default, use the router's address (192.168.2.1), use the same subnet mask as the router.  Use the Slingbox Setup Assistant to make these changes if necessary (I don't think it is for you).

           

          - The router needs a port forwarding rule that allows incoming connections on port 5001 through its firewall and on to the IP assigned to your Slingbox on the LAN.  Use the router's config tool to make these changes (usually by going to it's address with a web browser).

           

           

          You might be making things hard on yourself though.

           

          Since local viewing is working properly, you probably don't need to fiddle with the Slingbox.  It's likely that you just need a quick adjustment to your router's port forwarding.

           

           

          You can use this tool to guide you though the process manually for most routers:

          http://support.slingbox.com/get/old-network-assistant.html

           

           

          Setup Assistant can handle all of this automatically with some routers.  I'd suggest using the manual tool above since you probably don't need to make any changes to the Slingbox.  If you want to try to do it with Setup Assistant though, go here:

          http://setup.slingbox.com

           

           

           

          If you can't figure it out, post back with your router brand/model and the local IP for your Slingbox (192.168.2.xxx) and we'll take it from there.

           

           

          Hope this helps,

           

          - Az

            • Re: connecting to network
              miamiben

              My router is a belkin f5d8235-4 v2.0.  the ip for my slingbox is 169.254.115.136 according to Norton AV which sees the MAC address

              I cant find anything about port forwarding on the router set up page.Thanks

                • Re: connecting to network
                  ArizonaSackbut Apprentice

                  Hmm... those IP addresses look mighty fishy to me.

                   

                  First off, 169.xxx.xxx.xxx is usually a self-assigned IP.  Those tend to pop up when a device is asking for an IP address from the router over DHCP, but doesn't end up receiving one.

                   

                  Regardless, you mentioned that your router's gateway IP is 192.168.2.1.  That makes sense, but it also means your Slingbox should have an IP address that looks like 192.168.2.xxx.

                   

                   

                  Try going to support.slingbox.com, log in using your Sling account if you need to.  You should see information about your Slingbox.  If that info block shows up, post back and say what is listed under Internet Viewing for the Slingbox Private IP Address.

                   

                  Unless you're comfortable with what you're doing, I suggest you don't make any other changes to your router or with the Slingbox Setup Assistant just yet.

                   

                   

                  Since local viewing is working properly, I don't think this is going to be too hard to fix.  We just need to figure out a little more about your network then get the router configured.  We might need to make a change in your Slingbox settings, but I'm not sure yet.  We need to start by figuring out what IP is actually assigned to the Slingbox.

                   

                  I don't know anything about Belkin routers, so I'll try to look up some info on your model.  There has to be something in there to handle port forwarding, that's the next step.

                   

                   

                  I'll keep an eye out for your reply.

                   

                  - Az

                    • Re: connecting to network
                      miamiben

                      Local viewing only works when I wire directly from the slingbox to my laptop.  there is no info about my slingbox on file yet, because it won't go online.  Yes, I did have to manually change my router's IP because of a conflict with the modem.  Is there any way to connect to the slingbox to find out and change the ip adress manually becuase it seems like it is not getting an ip addresss inline with the router?  I did find where the port forwarding is on my router but it has two boxdes for inbound port and private port it looks like ________ - _________ for each, plus I can only asign the last digits of the ip so I don't know if it is even seeing the slingbox on the network.

                        • Re: connecting to network
                          ArizonaSackbut Apprentice

                          Thanks for the extra info, it helps.

                           

                          One thing I misunderstood was how you were watching the Slingbox locally.  I thought you were doing it though the router.  Instead, you said it only works if you connect the Slingbox directly to your computer.  So, local view is not working properly.  That bit of info helps greatly.

                           

                           

                          Is there any way to connect to the slingbox to find out and change the ip adress manually

                          Yep.  You do that with the Slingbox Setup Assistant.  The main problem appears to be that the Slingbox can't obtain an IP from the router.  If we can't make it work, we can get around it by assigning it a valid static IP.

                           

                           

                          I did find where the port forwarding is on my router but it has two boxdes for inbound port and private port it looks like ________ - _________ for each, plus I can only asign the last digits of the ip

                          You found it, that's it.  Inbound and Private ports should both be set to 5001.  It only lets you change the last three numbers of the target IP becuase the first three sets have to be the same as the router (attached devices need to be on the same subnet).

                           

                          If the router's gateway address is 192.168.2.1, all connected devices need to have an IP in the form of 192.168.2.xxx in order to work properly.

                           

                          I found a copy of your router's users manual, so I've got some screen shots now and can help a little with instructions.

                           

                           

                           

                          Here's what I suggest do now...

                           

                          First, try things the easy way.  If you've done this before, try once more please.

                           

                          - Connect your Slingbox directly to the router via ethernet.

                           

                          - Perform a hard reset:  With the Slingbox powered on, poke and hold the reset button for about five seconds.  Don't let go yet.  The lights will start flashing fast then slowly.  Let go when you get to slow blinking.  About 30 seconds later the Slingbox should be finished starting up.  When you get a solid power and network light, it's done.

                           

                          - Run the Setup Assistant again.  The Slingbox should still be connected via ethernet to your router.

                           

                          If this works, Setup will now be able to detect your Slingbox and you can proceed with configuration normally.  You'll be prompted early on to choose new hardware passwords for your Slingbox.

                           

                           

                           

                          If it doesn't work, try these steps...

                           

                          Manual Network Configuration

                           

                          - Go into your router's config pages.  Probably best if you use the browser's built-in site (192.168.2.1 by default) instead of the utility that came on its CD.  You don't need to make any changes yet, you're looking for the range of IP addresses reserved by its DHCP pool.

                           

                          - Once you have logged into the router you should see the Status Page:

                          Picture 1.png

                          (Click to Enlarge)

                           

                           

                          - On the left under LAN Setup click on LAN Settings.

                           

                          - On the LAN Settings page, look in the middle for the DHCP server block:

                          Picture 2.png

                          Note the IP Pool Ending Address.  You'll need that number shortly.

                           

                           

                          - Close out of the router's config site, you're done in there.

                           

                          - Connect your Slingbox directly to your computer via ethernet.

                           

                          - Run the Slingbox Setup Assistant.  Note that if you did the hard reset in the "easy" steps above, you might be prompted to choose new hardware passwords.

                           

                          - When you get to the networking part of setup, select options to manually enter your network/router details.  Use the following settings:

                           

                          • Slingbox IP: One number higher than the IP Pool Ending Address on your router, but not higher than 254For example, if the Pool Ending Address was 192.168.2.100, enter 192.168.2.101 here.

                           

                          • Router/Gateway: Your router's address.  From your description, it should be 192.168.2.1

                           

                          • Subnet Mask: From your description, it should be 255.255.255.0

                           

                          • Port: Use 5001

                           

                           

                          - Save the changes and finish up.  For the moment, you're done with the Setup Assistant.

                           

                          - Unplug the router from power

                           

                          - Move the Slingbox connection so it's hooked back directly to the router via ethernet.

                           

                          - Restore power to the Slingbox.

                           

                          - Once you have a solid power and network light, run the Slingbox Setup Assistant once more.

                           

                           

                          This time your Slingbox should be detected by the Setup Assistant though the router and you can finish setting things up for your video sources.  If it works, you have now successfully established a static IP for your Slingbox on the LAN.  Make note of the IP you chose (192.168.2.101 ?), it's a good thing to remember and might help later.

                           

                           

                           

                          Try these things, see how it goes.  Hopefully this totally fixes local viewing and you'll be able to watch the Slingbox from any computer at home that's using your Belkin router.

                           

                          We can configure the router and port forwarding for remote viewing once local viewing is working 100%.

                           

                           

                          Good luck !

                           

                          - Az

                            • Re: connecting to network
                              miamiben

                              I reconnected directly to my router did a hard reboot and it worked( Hooray!).  I know I tried it before but it worked this time so whatever.  Thanks again.  I will try logging in from work tommorow to confirm but so far so awesome!

                                • Re: connecting to network
                                  ArizonaSackbut Apprentice

                                  Awesome !   That's great news.

                                   

                                   

                                  Post back and say how remote viewing from work goes.  If it fails, we'll jump into that next.  It should be easier to get that running now that the Slingbox is behaving properly.

                                   

                                   

                                   

                                  - Az

                                    • Re: connecting to network
                                      miamiben

                                      I am at work now and is saying a firewall or something else is getting in the way.  I set the trust settings in Norton to full in the network settings already.  Any ideas?

                                        • Re: connecting to network
                                          ArizonaSackbut Apprentice

                                          It could be something at work (checking Norton was a good call), but it's most likely on your router.

                                           

                                           

                                          Early on we talked about port forwarding.  If that's it, what you need to do is go back into your router when you get home and set it so 5001 is pointed to your Slingbox IP.  I think there's enough info in our previous posts to guide you through that.  If you get stuck, say where and we'll take it from there.

                                           

                                           

                                          Since you're at work now (hopefully you get this in time), try going to support.slingbox.com (log in if needed) and look at the info block for your Slingbox.  That should be updated now.  Under Internet Viewing, you should see Setup Complete: Yes and no status alerts when everything is configured right.

                                           

                                           

                                           

                                          - Az

                          • Re: connecting to network
                            miamiben

                            Still not working away from home.  I already set the port forwarding on the router inboud to 5001-5001 and the private to the same what should the type be tcp/UDP or both?  Any other ideas?

                              • Re: connecting to network
                                ArizonaSackbut Apprentice

                                TCP/UDP = both.  Make sure the port forwarding rule is sending port 5001 TCP & UDP to the correct IP address assigned to your Slingbox.  If you check support.slingbox.com (log in if you need to), it should list the private IP your Slingbox is using under the Internet Viewing section.  That's the one you want to use.

                                 

                                 

                                See if that fixes it. 

                                 

                                 

                                 

                                - Az

                                  • Re: connecting to network
                                    miamiben

                                    It is working! 100% Thank you thank you thank you! I am watching it right now and I am thrilled

                                      • Re: connecting to network
                                        ArizonaSackbut Apprentice

                                        Outstanding !    Glad it's working for you.

                                         

                                         

                                        For future reference, you might want to print or save a copy of the thread.  We have been discussing the specific hardware and setup you have now, but we ended up covering enough stuff together that it should be a handy reference if you ever change routers, upgrade your Slingbox, etc.

                                         

                                        I recently discovered the View as PDF link on the top of the forum pages.  Duh ! It's in plain sight but I never noticed it before.  Nice way to save a thread.

                                        Picture 1.png

                                         

                                         

                                        Enjoy !

                                         

                                         

                                        - Az

                                          • Re: connecting to network
                                            sausageking

                                            Hi:  I have the same router and I am trying to manually configure.  But I am not able to connect directly to the Slingbox locally via ethernet in order to manually configure the slingbox to conform the the pesky Belkin router.  How can I access the Slingbox again?  Reset does not seem to work.

                                            • Re: connecting to network
                                              myaccino

                                              Hi AZ,

                                               

                                              Found your long but helpful work here.  I am getting an error message "Port conflect"  When I put in manually "Slingbox 5001,5001 10.0.0.254"  This use to work, but suddenly stopped.  I get the same error message on three computers including a WIN 7 that is brand new and shouldn't have any conflicts.  What do you think?  Thanks in advance.

                                               

                                              Mike

                                              • Re: connecting to network
                                                rockalittle

                                                Hope you don't mind me hopping on the bandwagon here but, my problem is similar to the others. I plan on reviewing this thread when I get home and confirming everything is correct. I was hoping to clarify 1 thing as soon as possible. Since moving my slingbox to a new room I have been sharing the ethernet cable between the slingbox and the xbox. I never use both at the same time so I was switching the cable between devices as needed. Is this causing the slingbox to reset every time I connect the ethernet cable? If so I will purchase a switch on the way home this evening.

                                                 

                                                Actually I'll purchase the switch anyway as it is becoming a nuisance continually moving the cable. Just think I may have been causing my own problem all along. (I've been at my wit's end for about 2 months now)