13 Replies Latest reply: May 5, 2013 5:42 PM by kentauta RSS

    HTPC flicker on Watch on Slingbox.com

    tcaradonna Novice

      I just assembed an HTPC that serves as my media hub for Live/DVR TV, DVD/Blueray playback, Amazon Prime Videos, Hulu, HBO Go and of course as a receiver for my remote slingbox streams.  Everything has been functioning great on the box without problems with the exception of Slingbox.com playback.  80% of the time when I'm connecting, I get the most annoying flicker.  Playback quality is otherwise perfection.  The flicker is limited to the playback window (the rest of the screen is fine) and seems to worsen when the remote is displayed. 

       

      I've tried this on 2 displays with similar results: my Samsung 56" DLP TV, and a Dell 23" LCD computer display, both connected to HDMI port on motherboard.  I am running the most current version of firmware drivers for all components.  The graphics is handled by the integrated GPU on the intel CPU (Intel HD4000).  No expansion cards installed (trying to keep it as low power as possible for 24/7 operation).

       

      Here are my pertinent HTPC specs:

      Intel i3-3225 (w/ HD4000 graphics)

      ASRock z77 Pro4-m (micro-ATX)

      Samsung 840 series 120GB SSD

      Seagate Barracuda 1TB HDD

       

      Windows 7 Ultimate 32-bit (x86)

      Firefox 32-bit

      Lastest flash version (11.6.602.171)

       

      There isn't much written about this problem on slingbox, or my motherboard forum.  I want to see if anyone else had this problem and if there were any potential solutions or suggestions to improve play performance.

        • Re: HTPC flicker on Watch on Slingbox.com
          kentauta Newbie

          I have had the same problem on multiple computers with Intel HD 4000.

           

          This happens when dynamic contrast (contrast enhancement) is enabled in Intel HD Graphics Settings and hardware acceleration is enabled on the sling player side.

           

          You can disable dynamic contrast.  The flcker problem will be gone, but there are some other problems like video becomes sluggish for a while after each remote control if the player is in the full screen mode.

           

          I recommend that you disable hardware acceleartion (uncheck Setting->ADVANCED SETTINGS->Enable H/W Acceleration).  This will bypass the problmes with HD 4000.

           

          I wish Intel or Slingmedia does something for this.  Video is a bit softer with the hardware acceleration disabled.  HD 3000 is fine btw.

          • Re: HTPC flicker on Watch on Slingbox.com
            tcaradonna Novice

            I tried disabling the HW accelleration as you suggested.  The flicker stopped for awhile, but seemed to come back.

             

            Do you suggest the renaming procedure to disable windows h.264 in Windows 7?  Is that a better solution?

            What are the chances that Microsoft rewrites this .dll?

              • Re: HTPC flicker on Watch on Slingbox.com
                tcaradonna Novice

                I read on another site that some of the new HD 4000 intel device driver "might" solve the problem.  I upgraded from 2932(released 12/18/2012) to 3071 (released 3/22/2013).  Flickering continued.

                 

                This time with 3071, I turned the HW accelleration off, the flickering went away.  So this is much better.

                 

                I also noticed that the flickering was very predictable.  Occurring the most after changing the stream, and interestingly, when going back thru the buffered video, would flicker in the exact same spots.  I was convinced I was watching a camera flash (it was a news press conference recording that I was watching), that I played back numerous time to come to that conclusion.  However, after upgrading to 3071 and turning of HW accelleration, the "camera flash" vanished!

                  • Re: HTPC flicker on Watch on Slingbox.com
                    tcaradonna Novice

                    Here's what I noticed with Watch Slingbox.com-->Settings-->Advanced Settings-->HW Accelleration checked ON/OFF:

                    It seems to change the Decoder from Microsoft DTV-DVD (ON) to SlingBox (OFF).  You can verify this by viewing the Stat window (control + left click).  When using the Slingbox (HW Accel OFF), the flicker disappears.  I think this has something to do with the fps rates that are possible with the Microsoft decoder (as mentioned in other threads).

                     

                    In fact, those users of the 350/500 claim to see unadvertised increases in fps rates under the Microsoft driver that yield smoother banner scrolling on HD channels.  (They attribute this to the increased fps.)  I have seen video of both now, and can say that their is a discernable difference between the two although the stats window do not report the higher fps.  The difference was present yet very small to me, but very noticable and distracting to others.  I suppose if I watched it for long periods of time it would get to me too, but I've only done minor experiments at this point.

                     

                    So, after doing some more searching, it seems that another Intel setting called image enhanement or dynamic/adaptive contrast can eliminate the flicker problem in the Microsoft DTV-DVD decoder.  Here is a video demonstrating the problem (in this case affecting Windows Media Center):

                    http://www.youtube.com/watch?v=9g6Z1sWOOIA

                     

                    There seem to be at least two ways to disable it (depending on how its refered to in your system) both in Intel control panels:

                    1.  Most: Media > Image Enhancement > Adaptive Contrast Enhancement  See: http://communities.intel.com/message/188055#188055

                    2.  Mine: Video-->Image Enhancement-->Contrast Enhancement

                     

                    So, my problem seems solved.  I'm running HW accel ON (microsoft decoder), with Contrast Enhancement off.

                      • Re: HTPC flicker on Watch on Slingbox.com
                        kentauta Newbie

                        Yes, disabling dynamic contrast in the Intel driver settings does eliminate the flicker as I mentioned in the previous post.  The combination of the MS codec and H/W acceleration does provide nivce smooth video, but I am experiencing a problem with it on multiple computers with Intel HD 4000.

                         

                        In the full-screen mode, the video starts stuttering after any remote control (like changing the channel) so I am forced to exit to the window mode and return to full-screen mode for each remote control.

                         

                        Don't you have this problem?

                          • Re: HTPC flicker on Watch on Slingbox.com
                            tcaradonna Novice

                            Sorry, you did refer to it before, but I didn't realize at the time that "dynamic contrast" and "Contrast Enhancement" (which is how it's referred to in my system) are the same thing.  It took me until later to make the connection, but you definitely had it right.  It seems this is a fairly well established issue not specific to Slingbox.  (One source even suggested that it is not specific to the HD 4000 either!)

                             

                            As for full-screen operation, I'm not having any difficulty as you described.  The remote functions essentially normally.  The only thing I notice is as the remote appears or disappears, the stream goes back a fraction of a second in the buffer so an ever so small amount of the video is repeated.  So far, that's the only quirk I've noticed with Dynamic Contrast/Enhancement turned off.  I should mention that I use Firefox 20.0.1

                              • Re: HTPC flicker on Watch on Slingbox.com
                                kentauta Newbie

                                No problem.  It looks that Intel changed the name for Dynamic Contrast to Contrast Enhancement in the latest driver update.

                                 

                                Thanks for info from your side.  I have tried Firefox 20.0.1 as well as Chrome 21 and IE10 on a Windows 7 (64b) machine.  They all have the same video stuttering problem in full screen after remote control...

                                 

                                Do you use 64-bit Windows or 32?

                                  • Re: HTPC flicker on Watch on Slingbox.com
                                    OvCollyer Apprentice

                                    I'm guessing that might possible have been a reply to me (a bit confusing the way replies work on these forums isn't it?) - but either way I can confirm I'm using Windows 7 Home Premium 64 bit edition, with all the latest updates installed.

                                     

                                    What version of driver are you using for the Intel HD 4000? Mine is 9.17.10.2932 dated 12/12/2012. The PC is an Intel NUC Core i3, and the driver is the one I downloaded from Intel's website for this PC.

                                     

                                    The option I used to get rid of the flicker was called "Adaptive Contrast Enhancement" under the Media -> Image Enhancement section of the "Intel Graphics and Media Control Panel".

                                      • Re: HTPC flicker on Watch on Slingbox.com
                                        kentauta Newbie

                                        Sorry for the late reply.

                                         

                                        I am also using Intel Core i3 NUC (DC3217IYE) but with Windows 8 (64b).  The version of the Intel graphics driver installed on this machine is 9.18.10.3071, which is the latest one from Intel.  On this machine I have only tried Google Chrome.

                                         

                                        The other machine I have is Lenovo ThinkPad X1 Carbon with Core i5.  Windows 7 sp1 (64b) runs on this machine.  The same graphics driver is used, and I have the same stutter problem with Chrome, Firefox, and IE10 even with Contrast Enhancement turned off.

                                         

                                        Would you mind sharing your system information generated by the Intel graphics control panel?  Mine is attached to this post.

                                      • Re: HTPC flicker on Watch on Slingbox.com
                                        tcaradonna Novice

                                        Windows 32bit Ultimate (So I guess there is that difference for us.)

                                        Ultimate has the language packs which I need.

                                         

                                        Before putting together my HTPC, I asked on the boards here which OS version would be best (Slingplayer was a major function of this PC).  A product manager from Sling recommended I go with 32bit.  So I did.

                                        https://community.sling.com/message/85151#85151

                                         

                                        I haven't been completely convinced that 64bit would get me very much (other than the obvious larger realized memory access).  So even though I waste some of my physically installed memory, the overall demands of an HTPC don't really to need it.  (At least for now)

                                    • Re: HTPC flicker on Watch on Slingbox.com
                                      OvCollyer Apprentice

                                      @kentauta

                                       

                                       

                                      I have an Intel HD 4000 and I don't have this problem. Well, there has always been a couple of seconds of stutter after issuing remote commands on every Slingbox/player I've tried, but it doesn't carry on indefinitely which sounds like is what is happening for you?

                                       

                                       

                                       

                                      What browser and OS are you using? I've tried with both Google Chrome and Internet Explorer 10 under Windows 7 and I've not had the issue you are experiencing.

                                       

                                       

                                       

                                      Disabling contrast adjustment also fixed the same flickering I was experiencing, by the way - thanks for that.