12 Replies Latest reply: Dec 24, 2012 1:58 AM by jhaysom RSS

    Regarding firmware 1.1.52

    OvCollyer Apprentice

      I noticed this has been pushed out (thanks for this) so I'm hoping to give the WDTV another try and see how it's improved.

       

      I've not received this update (I've checked via Slingbox Info on the settings page @ newwatch, aswell as the support page) yet, it's still showing 1.00.055 for me.

       

      So how long should I give it before I can assume the update has failed? Do these things rollout over a period of time?

       

      It's just that I'm only rarely at the location the SB (and nobody else is there) so a hardware reset would be problematic. The box does power cycle overnight on a mains timer though, so might that give it a nudge?

        • Re: Regarding firmware 1.1.52
          keith.sling Apprentice

          Hello OvCollyer,

           

          Thanks for using our answers forums! Here is our latest article which describes how to check and update your firmware. It also lists the most up to date versions of firmware for each Slingbox model.

           

           

          Hope this helps!

           

          Regards,

               The Sling Moderation Team

            • Re: Regarding firmware 1.1.52
              OvCollyer Apprentice

              Your reply does not answer the Q I asked.

               

              Did you even read my post properly?

               

              As I said, I've checked my firmware version and it is still the old one. I was asking how long it might take to automatically update.

               

              The article you link to contains an incorrect version number for the 350's new firmware, so it's useless in any case. In 'what's new' you list it as 1.1.52, in the article you linked to it is shown as '1.0.52' which is older than the current firmware I have of '1.00.055'.

            • Re: Regarding firmware 1.1.52
              DAN20

              I haven't had the update yet either, i was streaming and got disconnected and there was a list of reasons, one of which was possibly updating.  Not sure if i clicked on what's new or this post but i've checked and the firmware i'm on is still 1.0.52 and the firmware date is showing as 10/9/2012.

               

              I'm wondering whether trying to reconnect stopped the slingbox from updating or whether it's just a case of waiting, i've read it's supposed to be automatic but don't know if the slingbox will just periodically check for updates or not as the firmware update is supposed to be on the 19th.

               

              Hopefully the firmware will still update and the issues it's supposed to fix are going to be as the firmware notes are claiming.

               

              Anyone received the update?

                • Re: Regarding firmware 1.1.52
                  OvCollyer Apprentice

                  My firmware is listed as 1.00.055 which has been the case since I installed the box.

                   

                  In 'what's new' they list the new firmware as being '1.1.52'.

                   

                  In the article KWhit pointed me towards above, latest firmware is listed as '1.0.52'.

                   

                  Nothing like making things clear is there!

                • Re: Regarding firmware 1.1.52
                  OvCollyer Apprentice

                  Sling, are you sure you've actually rolled out the new firmware?

                   

                  Since I have a spare 350 here I did a test; I factory reset it and it downloaded a firmware update.

                   

                  However, upon completion of setup, it still shows that it has firmware version "1.0.55".

                  • Re: Regarding firmware 1.1.52
                    OvCollyer Apprentice

                    Ok it seems my slingbox has now updated.

                      • Re: Regarding firmware 1.1.52
                        DAN20

                        Checked my slingbox today and it has also updated.  Noticing a slight improvement with regards to stability but it's far from perfect.  Best HD does last for more than half a minute but does eventually freeze at some point, on this quality and others it does seem to recover sometimes but ofcourse with greater buffered seconds making commands painfully slow.

                         

                        I'm thinking that the slingplayer app for WDTV that is for the newer slingboxes could also be partly to blame, sling and wdtv need to work together to get this fixed to work as flawlessly as the pc app did, even via 'watch' it works better.  The app doesn't connect straight away (while optimizing), it takes 3 more seconds still so there is still a total delay of 6secs.  As people say sling blame wdtv and visa versa even though sling stated back in october that they was working with wdtv to get an updated slingplayer app to work with the 350/500 by the end of october.

                         

                        I appreciate the increase in stability, was streaming on the better quality while typing this and it just froze just shy of 32mins, throughout that time skipping forward a few times (always need to space out commands by 3secs or 3 quick commands for a channel to avoid a freeze), the stream did recover with increased buffered secs, pressed info and it took 18secs to see the info banner and 20secs for the cycle to complete.  This is remote viewing, wdtv is connected via ethernet and speedtest results via the APP are around 12Mbps and from the slingbox just under 4Mbps.

                         

                        If the tech guys are infact working on resolving the issues they have got to test it remotely and 'put it through it's paces'  streaming on all qualities and the commands issues.  As it is, it still needs work.

                          • Re: Regarding firmware 1.1.52
                            OvCollyer Apprentice

                            That pretty much mirrors my experience with the new firmware.

                             

                            It's definitely more stable for me, in that if the connection fluctuates or if I download something else at the same time to swallow the bandwidth, then whereas pre-update it would freeze permanently and I'd have to reconnect, post-update it always seem to recover, for me at least.

                             

                            However, it isn't much use if it recovers and the buffer is so large that subsequent commands take anything up to 30s!

                             

                            I can also easily make it gain this huge buffer/delay state simply by choosing a few commands in quick succession. For example in the Sky EPG I would typically (with the Slingcatcher connected to a Pro-HD) hit the right arrow 5/6 times quickly to get to the category I want (Sports, say) but this invariably freezes the stream for a while on the WDTV and when it recovers any further commands are futile unless you have the patience of the saint.

                             

                            So in short, progress has been made, but there is still a way to go and it still feels very much like a beta product to me. It's a bit disappointing because these delayed commands have been reported consistently right back to the release of these *players but still no fix for that.

                             

                            At least we're making some progress, I suppose.

                             

                            *worth noting that the delayed commands issue is equally reproducible for me on both the Sony and Vizio Google TVs

                              • Re: Regarding firmware 1.1.52
                                DAN20

                                I lost connection while streaming again today with a list of possible reasons why, I checked the details of the slingbox and it says last update received was today '12/21/2012', the firmware version is still 1.1.52 so not sure if they've been reading the posts and attempted a tweak of this version of the firmware.

                                 

                                At the time i gave it 10mins before i tried to reconnect and found that information, i've noticec that the delay for commands has increased to 7secs!!, i usually count 1 mississippi...... and usually get to 6 but now it's 7!!, only counted it as it seemed even slower than usual and turns out that it is, i think the stream started slightly later than the usual 3secs too which would explain it.

                                 

                                Strange thing also is that on the slingbox details on the site it says last update as 21st BUT if i click on watch (old style) and options it says firmware date 12/12/2012.

                                  • Re: Regarding firmware 1.1.52
                                    OvCollyer Apprentice

                                    Hmm, well I have two Pro-HDs on my account too which also show last update received as 21st December, so I'm not sure if that can be relied on.

                                     

                                    Sometimes I think if the initial connection isn't smooth then it can start in a slightly over-buffered state with delayed commands. I noticed yesterday I must have connected when my connection was temporarily dipping and I immediately had a 15s delay on commands. This is very rare though.

                                     

                                    The WDTV is quite close to being very usable, I must admit. I can just about live with the delay being the 5s or so, but I can't accept that it could change to 10-20s at a whim, for example if I downloaded something from itunes at the same time this could screw it up as it deals with the reduced bandwidth. That shouldn't happen.

                                     

                                    I much prefer the WDTV player to the Google TV players because there are direct button mappings for Guide and Back on the remote for controlling my Sky box which don't appear to exist on the GTV players without turning the remote control over and accessing the fiddly keyboard. Also, it's easy to set the WDTV up with a universal remote like the Harmony, which means I can map the yellow (guide) button and return/back button to the Guide and Exit buttons on the Harmony, the stream info to the Info button, and the blue control button to the Harmony's Menu button, which makes it all pretty usable. It's slighty inconvenient that there is no mapping for the power on/off so you have to use the control overlay for that. Perhaps rather than map the red button to the stream info, they could map the power toggle instead and move the stream info somewhere else, I don't know.

                                     

                                    Next improvement for all the connected device players has got to be to fix the delay getting longer. It surely can't be that hard to have it working like the web player and Slingcatcher in that it is 1) snappier and 2) doesn't end up in this messed up delayed PIA state.

                                     

                                    Come on Sling, you're getting closer!

                                      • Re: Regarding firmware 1.1.52
                                        DAN20

                                        I've found the buffer to be the same as usual until recently, yesterday i had a few instances where it was a lil longer on the buffer and also experienced a very lengthy buffer like you did where the initial progress bar took a long time to complete, then a long time before it streamed etc until i reconnected.

                                         

                                        I've thought about using a remote like the harmony BUT there aren't that many buttons that are mapped compared with the old pc app/webplayer which has some sort of keyboard shortcut for maybe 90% of the buttons and almost everything else can be accessed via menus.  The app used for wdtv has always seemed to me like an app originally made for the boxee and revue as the shortcut letters are made for those devices that have a qwerty keyboard.  In general it does seem strange that they would limit the amount of shortcut commands in this way given how many keys are available.

                                         

                                        If i connect my laptop to my tv i use an android app called droidmote which has customizable buttons, 3x4 grid of buttons per profile.  Hopefully in the future there might be an update for connected devices where more commands have a quick shortcut, i'd definately be interested in a harmony then.

                                         

                                        If GTV has a slingplayer app that is about the same as the others, does the ability to use a browser on GTV make it possible to stream with the webplayer and would the shortcuts for the remote work, WDTV does have a hidden browser but it doesn't support flash and isn't usable with the supplied remote.

                                          • Re: Regarding firmware 1.1.52
                                            jhaysom Newbie

                                            I too have issues with this firmware.

                                             

                                            channel watermarks appear "jumpy" like they are vibrating rapidly.. im getting better Mbps flow now (used to cap at 4 and now it goes to 6-7) however there is no noticable improvement in quality.

                                             

                                            the vibrating effect is really bothering me and its not something that happens on my actual cable box (i.e. its not reencoding an already jumpy capture)

                                             

                                            what can be causing this?