4 Replies Latest reply: May 22, 2010 4:35 AM by Bryanod RSS

    Remote Viewing with Multiple Routers

    lancebarker

      I'm trying to set up my Slingbox for remote viewing and haven't had any luck.  My home network is set up like this: a Verizon Fios Actiontec wireless router as my primary router which is then hooked up to a Belkin wireless router on the other side of my house via ethernet, this Belkin is then hooked up to the Slingbox.  I have gone into both of the settings for the routers and forwarded port 5001, but I still can't seem to get remote viewing to work.  Any suggestions?

        • Re: Remote Viewing with Multiple Routers
          ArizonaSackbut Apprentice

          Hi Lancebarker,

           

           

          Have another look at your Belkin router.  I suspect the problem is that it's configured to be a gateway router and has built a wall around your Slingbox through a combination of NAT/DHCP and a firewall.  Even if you forward 5001 through the Belkin firewall (which you shouldn't need to- you don't want it to put up a firewall), it will goof up how SlingID works and you won't be able to remote view.

           

          I don't know Belkin routers well enough to offer a step-by-step, but you're looking for a way to disable NAT and have it behave as a router instead of a gateway.

           

          Your Actiontec router should be handling security, everything attached to it needs to allow for open, unrestricted communication.  This isn't the only way to set things up, but it is common and I think it will solve your problem.

           

           

          By the way, are you running active wifi on both the Actiontec and Belkin routers ?

           

          Hope this helps,

           

           

          - Az

            • Re: Remote Viewing with Multiple Routers
              lancebarker

              Thanks for the response.  After trying to disable just the firewall, the problem still persisted.  I then disabled NAT and after that the router was not able to connect to the internet.  Any suggestions?

                • Re: Remote Viewing with Multiple Routers
                  ArizonaSackbut Apprentice

                  ...not regarding the Belkin router.  Sorry, I just don't know enough about those and I don't want to lead you on a wild goose chase.

                   

                   

                  Regarding remote viewing, the only thing I can suggest is to try connecting the Slingbox directly to the Actiontec as a test.  Since you've got an ethernet run from there to the Belkin anyway, I hope that wouldn't be a major pain to try.  If you do, the Slingbox might not respond normally because it'll be connected to a different router (wrong internal network settings) and require a reset.

                   

                   

                  Basically, try to isolate which router is causing the problem.  If you know it's the Belkin, no need to bother with what I said above- you just need to find someone who knows more than I do.   If not, seems reasonable to check the Actiontec so you can rule it out and know where to focus.

                   

                   

                  If you don't mind, what model Actiontec and Belkin routers are you running ?  If I happen to run across something useful on either one, I'll post it.

                   

                   

                   

                  Good luck,

                   

                  - Az

                  • Re: Remote Viewing with Multiple Routers
                    Bryanod Novice

                    If you connected the actiontec lan port to the belkin wan port you created 2 NAT networks. To get the sling to work remotely you must do 1 of the following.

                     

                    On the belkin router Configure the wan ip as a static ip The static ip must fall into the same range as the lan ip on the actiontec router.  Forward port 5001 to the sling ip.  Then login to the actiontec router.  Forward port 5001 to the wan ip of the belkin router (not the slingbox ip)

                     

                    or

                     

                    Connect the actiontec lan port to the belkin lan port and disable dhcp on the belkin router.  The lan ip of the belkin must be on the same network as the actiontec.  This setup is best as all devices are on 1 network.