5 Replies Latest reply: Oct 15, 2012 8:47 AM by Morac RSS

    Remote .spr files are not downloading (not displaying correct remote)

    Morac Newbie

      I have a HD Pro which is connected to a TiVo S3 and a TiVo Premiere.  For awhile I was using a custom skin for the TiVo Premiere (V1111) and the default remote for the TiVo S3 (V1295).

       

      Yesterday I connected to my Slingbox from work using Firefox 16 (after upgrading plugin) and the remotes were correct.  Last night I went and set up my Premiere to use the built in Premiere remote (V1504) with a modified BIN to change the remote code.  When I tested this at home on my laptop it worked fine.  The Premiere remote downloaded (during setup I think) and worked and the existing S3 worked (though it did briefly switch to the default TiVo remote, it changed back).

       

      Today at work both my Premiere and S3 were using the default TiVo.spr file.  I tried removing all the .spr files (TiVoS3, TiVo and Default) from the ...\Application Data\Sling Media\WebSlingPlayer\Remote folder, but then the remote didn't display at all and new .spr files were not downloaded.  I added them back and it showed the default TiVo.spr remote again.  I removed the TiVo.spr file and now my S3 displays the TiVoS3.spr remote, but the TiVo Premiere displays the Default.spr remote (which is wrong).

       

      I tried clearing cache and cookies and even VPNing to my home, nothing worked.

       

      I checked the WebSlingPlayer.txt log file and it says the remote data comes from http://services.sling.com/slingservices/rest/v1/remotes/deviceType/<devicetype>/manufacturer/<manufacturer>/irSetupCode/<irSetupCode>, and I can manually go to those sites in Firefox and download the files, but for whatever reason it simply won't download the remote data.  It says "No remote control updates found". 

       

      I manually downloaded the TiVo Premiere V1504 TiVoGloPremium.spr file and I can see in the log file that it knows it's there as it lists the default.spr and TiVoGloPremium.spr files as avaialble for the Premiere, but then it picks default.spr.

       

      I can't figure out why this doesn't work, especially since on my iPad the Premiere and S3 skins show up fine.

       

      Any ideas?

        • Re: Remote .spr files are not downloading (not displaying correct remote)
          Morac Newbie

          I think this might be a proxy/firewall issue.  It doesn't look like the plugin is using the proxy/VPN I set up for Firefox to use when connecting to the Sling web site since when I look at the log file I see that connections to services.sling.com are being blocked.  Not sure how to go about fixing that.  I would be nice if there was a way to force the plugin to use the remote I specified.  I tried simply replacing the default.spr with the TiVo spr, but then most of the buttons don't work.   I could use the "Default" remote, but then the TiVo (menu) button doesn't work.  I guess there's nothing I can really do to force things to work here.

           

          What's odd is that streaming works fine, only the remote is screwed up.

           

          Any way of setting up the plugin to use a proxy?

            • Re: Remote .spr files are not downloading (not displaying correct remote)
              alanrichey42 Master

              I would try installing the standalone Slingplayer and setup the video inputs with that.  if they don't download then put the SPR files into C:\ProgramData\Sling Media\Slingplayer\2.0\Remotes\  (You would need to check "View Hidden Folders and Files")  or  /Applications/SlingPlayer/Contents/Resources/Remote if you have a Mac.

               

              The big advantage now is that by using the Connect > Remote Keys menu option you can switch the remote that is being displayed (this function was removed in the web-player).   And this selection will subsequently be reflected in the Web-based player.

              • Re: Remote .spr files are not downloading (not displaying correct remote)
                BrandonC Novice

                 

                What's odd is that streaming works fine, only the remote is screwed up.

                 

                 

                I thought your post on the Place Shifting Enthusiasts site said you got the remote working. No?

                If not post again where you are at and maybe we can help.

                  • Re: Remote .spr files are not downloading (not displaying correct remote)
                    Morac Newbie

                    I got it working on my home computer, iPhone and iPad. It's just my work computer that's having an issue.   I'm pretty sure it's because Sling disabled the ability to set a proxy at newwatch.sling.com.   My work blocks access to services.sling.com which is what the plugin tries to connect to to get remote and other data.  I set up a socks proxy around the block, but the plugin won't use it (according to the webslingplayer.txt log file).  Sling apparently disabled that feature on the new site.  See http://support.slingbox.com/get/KB-2000504.html

                     

                    What's confusing me is that I manually downloaded the remote spr files and one worked eventually (TiVo S3) and the other always shows the default and doesn't map all the buttons (Premiere).  It would seem like either they should both work or both not.  I can't figure out why unless I downloaded the wrong spr file somehow.  My next test will be to copy the webslingplayer folder from my home PC to my work PC and see if that makes a difference.