11 Replies Latest reply: Mar 17, 2014 10:45 PM by jlehrer RSS

    Slingbox stops using DHCP, hard coded 192.168.1.254?

    jlehrer

      My slingbox seems to always use 192.168.1.254.

       

      I reset the slingbox holding the reset button on the back.

       

      I can confirm that on the first boot it did obtain a different IP address via DHCP (by looking at the router logs and pinging that new address).

       

      However, during the setup procedure, after a reboot, it started using 192.168.1.254 and does not use DHCP anymore.

       

      Is there a way to force the slingbox to use DHCP?  My intention is to ensure that the router always gives it the same IP address (which I can do), but leave the sling in DHCP mode.

       

      Help?

       

      Thanks,

       

      joshua

        • Re: Slingbox stops using DHCP, hard coded 192.168.1.254?
          jlehrer

          Does anyone from sling monitor these boards?  A quick google search shows lots of people having this same problem.  Does slingbox not do proper DHCP?

            • Re: Slingbox stops using DHCP, hard coded 192.168.1.254?
              tcaradonna Novice

              Try looking at the DHCP server.  I use a Netgear WNR2000.  It allows me to "reserve" an IP address for any MAC address.  It could be that the slingbox IP address is being forced from there.

                • Re: Slingbox stops using DHCP, hard coded 192.168.1.254?
                  jlehrer

                  I did.  In fact, I have attempted to reserve a different IP address for the slingbox.  It boots, takes the IP address that I have reserved for it, then after a few minutes it falls back to 192.168.1.254.

                   

                  I believe it is not using DHCP correctly and is just looking for an unused address starting at 192.168.1.255 working downwards.

                   

                  Are you able to reserve an IP address for it on your router and have it respect that reservation?

                    • Re: Slingbox stops using DHCP, hard coded 192.168.1.254?
                      tcaradonna Novice

                      I haven't tried it on the slingbox, but I have for other devices on my network and it works.  Nor do I use DHCP on my slingbox,  I set the IP address thru the slingbox setup utility.

                       

                      How are you verifing that the address changes?  I did notice recently, that whenever I go back to the utility, it puts the IP address to 192.168.1.254 (not what I assigned during the first setup).  This made me think the address was changed.  However when I look at the list of attached devices on my firewall, it shows up as the address I assigned to it.  My guess is that the utility doesn't populate current values in the setup fields and tries to assign the default address.  If you ignore it, it should stay how you set it.  Not sure if that's your problem, but I thought I'd mention that.

                • Re: Slingbox stops using DHCP, hard coded 192.168.1.254?
                  infobleep

                  I'm having similar problems, although I'm not trying the same thing. Firstly I thought it was my fault and although I had made a mistake, actually there is a problem.

                   

                  I have assigned the Slingbox a static IP address of 192.168.1.70. I also have a non standard port 9999, since I wish my NAS device to use port 5001.

                   

                  So I test the slingbox and it says I'm ready to view over the Internet. If that is the case then why doesn't my app connect via my 3G connection? It wouldn't be because I'm not connected to the Internet would it? Surely not. Slingbox interface says I am. What a load of rubbish. So I click on advance settings to actually try and make me ready.

                   

                  Next I set yes to the app optimiseation. Finally I enter in the details mantually. These being the details which should make it work. Next I hit test and it goes back to the test routine and then tells me it's all set up. Well why can't I connect to over the Internet it if it's all set up? So I go into advance. This time it does have my new IP address of 192.168.1.70, instead of 192.168.1.252, which it had previously. However the port has been put back to 5001. I thought I was allowed to use my own port. Clearly not, despite being given the option to do so. At this point I can't see what I am doing wrong.

                   

                  I have set up port forwarding for that port 9999 and assinged it to the Slingbox mac address. What else can I do?

                   

                  Now I could give Slingbox a ring but to do so would cost me at least £120. That mean my daily rate as a contractor, since Slingbox technical support is only available during Office hours and I would have to take the day off work. I am not in a position where I can work from home. Now I can't ring them from the office because my Slingbox can't connect to the Internet with the non-standard settings.

                   

                  Now I know this is a user forum but personally I take the view that companies should respond to their user fourms. I work within IT and one piece of software I use costs £3000 per year in addition to the technical support contract costs. Despite all of that, the software company still replies to people's topics in their user fourms. In this case I make use of both the forums and the one to one technical support. I find both very useful. The former is great for finding out answers to previous queries that match your own, where as the latter is useful for those times when you can't find it online.

                   

                  I think Slingbox and others should follow suite. But I'm probably talking to a brick wall here.

                   

                  Kind regards

                  • Re: Slingbox stops using DHCP, hard coded 192.168.1.254?
                    jlehrer

                    I am still having the same problem.

                     

                    My slingbox pro hd does not appear to do DHCP properly.  It always uses the IP address 192.168.2.254.

                     

                    I have tried reserving an IP address for it in the router's DHCP static reservation table by mapping it's MAC address to a different IP address and that doesn't work.  I have done the same for lots of other network appliances in my home and they all get the DHCP reservations correctly.

                     

                    I am convinced that this is a Slingbox bug.  It appears to skip DHCP and instead start at the top of the IP range looking for the first available address.

                     

                    Can anyone from Slingbox help me out here?

                     

                    Thanks,

                     

                    J

                    • Re: Slingbox stops using DHCP, hard coded 192.168.1.254?
                      Katmeat

                      I'm having this same problem.  i just switched to Uverse and the NVG589 modem, which uses 192.168.1.254 as its address.  Now I cannot get my Slingbox to be recognized on the network, even after numerous resets, apparently because it is stuck with the same IP address.  The new router does not let me allocate an IP address to an undiscovered client, so I am stuck.

                       

                      Any suggestions?