1 Reply Latest reply: May 1, 2012 10:09 PM by Matt.Sling RSS

    Compatability issues with OS??

    lharbinson

      Am trying to install my new Slinbox using Mac Snow Leopard and Firefox v12.  Thought I was finally nearly there when it says OS and browser not supported when the 'helpful' table says they are.  Please help!