4 Replies Latest reply: Aug 25, 2012 9:03 AM by tkelvis RSS

    Connection Timed Out (code 10003)

    AEGelfand

      I'm having trouble accessing my Slingbox from my Boxee tonight.  It usually works (provided the Slingbox is working), but now I'm getting an error that says 'Unable to connect to Slinbgox' and 'code: 10003'.  I can connect to the Slingbox fine on my computer in the same room so I'm not sure what the problem is.  I turned the Boxee off and back on but other than that I'm not sure what to do.  Anyone have any thoughts?

        • Re: Connection Timed Out (code 10003)
          nabilazhar

          I'm having the same problem. Worked just fine a couple of days ago. I have no idea what happened. I'm extremely frustrated and it is not encouraging to see that this post has been unanswered for 6 months!

          • Re: Connection Timed Out (code 10003)
            mkmichaels

            I, too, am having the same problem. This is my second Boxee. The last one I had for 2 days. The first day it worked. Second day, Connection Timed Out (code 10003), Exchanged Boxee for this one as the phone help (?) for Boxee thought there might be an issue with the box itself. Not so, as this Boxee doing the exact same thing, except I didn't even get the one day out of it. Slingbox should not have sold the rights to Boxee if it isn't going to work. I am a little aggravated and would like to return the Boxee, the Slingbox with all its accoutrements, and just get cable already at this cottage in northern Michigan.

            • Re: Connection Timed Out (code 10003)
              tkelvis

              I am now getting the same problem... code:10003 error when trying to conenct the Boxee box, but Slingplayer works fine on my Mac (with 2.2MB/sec tranfser rate).  Very frustrating.  has any solution been offered.

                • Re: Connection Timed Out (code 10003)
                  tkelvis

                  I think i figured out the problem with my Boxee Box... and this was with my MAC book working the Slingbox just fine!!

                   

                  My home network router is a Mac Time Capsule with the Router inside.

                   

                  Slingbox Helpdesk was no help as I waited for over an hour on hold and gave up… Sunday afternoon in August.

                   

                  This “Setup Internet Viewing” can only be performed on the home network where the Slingbox is located… even though the problem manifests when you are viewing in a remote location.

                   

                  Go to Slingplayer @ http://watch.slingbox.com/watch

                   

                  select “Options” button in the upper left part of the screen window

                   

                  select “Slingbox Setup” on the lower left side of the screen

                   

                  select “Setup internet viewing”.  You will get an auto run program that will show a progress bar to “testing that everything is ok for internet viewing”.  I got the message

                  Ready for Internet Viewing

                   

                  You are now all set to watch TV on your   Slingbox from anywhere.

                   

                  To make changes to your Internet Viewing   settings, click on Internet Viewing advanced settings.

                   

                  The above message was completely meaningless.  I used the auto mode originally, but it did not set up my router correctly.

                   

                  So I selected “Internet viewing Advanced Settings”… and  “manually configure my router” set up option button.  I used the “step-by-step” utility on the left hand side of the screen.

                   

                  To solve the problem on my MAC Time capsule router (with is likely different for any other brand of router, but they have a pull down list of brands and routers), I had to

                  • Open AirPort utility (Finder, Applications, Utilities, AirPort)
                  • Select Airport base router
                  • Select “Edit” the settings (Note: the screen shots from Slingbox Support were completely wrong for MAC OSX Lion, but I figured it out.)
                  • Select “Network” tab in AirPort
                  • Select “+” on Port settings

                  ·      A new port setting will be established for “IPv4” settings.  I named it “Slingbox Port”

                  ·      Enter the following info in quotes for the requested info

                     o   Public UDP Ports “5001”
                  o   Public TCP Ports “5001”
                  o   Private UDP Ports “5001”
                  o   Private TCP Ports “5001”
                  o   Private IP address “10.0.1.54”

                   

                  In checking my Boxee Box with Slingplayer app, it is back working and MUCH better.

                   

                  It seems that completing this setup also cured the command issue (failing to respond to Boxee remote commands) as well as the issue with Slingplayer disconnecting and having to reconnect it.

                   

                  What I can’t appreciate is why this info is SO BURIED in the support page.  This should have either been 1) part of the original automated setup (even if it gives an error message) or 2) crystal clear that you MUST complete these steps prior to remote internet viewing (especially because you CANNOT fix this setup remotely and have to be on your home network).

                   

                  None of this info was anywhere in the basic setup or troubleshooting info.  I simply stumbled on it while waiting for an hour on hold.  While I am satisfied that I fixed the problem, I would give Slingbox an “F” in their customer support and troubleshooting.  Slingbox really needs to massively improve their support to be a credible consumer electronics business.