6 Replies Latest reply: Apr 30, 2010 1:29 PM by ArizonaSackbut RSS

    Losing remote connection to slingbox

    jcafaro10

      Every once in awhile I lose the ability to remotely connect to my slingbox.  The problem is fixed by having someone at home run through the config again.  The slingbox works fine over  the LAN even during the time when I can't connect to it here.  I'm not sure what to do to fix this.  The IP of the slingbox ends in .259 and for my router (wrt54gs) this is outside of the DHCP range so it's just like assigning it a static ip.  What could be causing this?

       

      Also, I find that if I can't connect to it and I'm too lazy to call home and have my brother run through the configuration, if I try back again the next day it might work without anything having been done.

        • Re: Losing remote connection to slingbox
          robbr Newbie

          One trick a lot of us have used it buying timers and putting them on the Slingbox and even the router.  With the timer turning everything off late at night it usually seems to clear up the issue with losing the connection.  Sounds like your router and Sling lose sight of each other, which can happen over time.

            • Re: Losing remote connection to slingbox
              jcafaro10

              Why would my router and slingbox "lose sight of each other"?  The Slingbox doesn't go anywhere.  Wouldn't the router keep a map of the slingbox's mac address to it's ip address (which also shouldn't change).  What is a timer?  I don't want my slingbox and router automatically turning off when people are trying to usethem.

                • Re: Losing remote connection to slingbox
                  ArizonaSackbut Apprentice

                  Hi jcafaro10,

                   

                   

                  You're correct that if you park your Slingbox on an IP outside of the DHCP range but within the subnet, you've given it a static IP.  That's all that is required: Assign the IP in the setup assistant making sure it's on the same subnet as the router, Avoid the router's DHCP block.

                   

                   

                  I use WRT54G's also...  try moving your Slingbox to a static IP a little lower.  Like just before or just after the DHCP block.

                   

                  Those routers start DHCP by default at 192.168.1.100.  I moved my block to start at 192.168.1.110, using 100-109 for static assignments.  I didn't have to do it this way, it just made things easy to remember for me.  I could have just as easily started static IPs after the default block.

                   

                   

                  Obviously, you'll need to adjust your port forwarding rules too.  Get in your router, click Applications & Gaming and change your port 5001 entry to point at the new Slingbox IP.  TCP/UDP = Both.

                   

                   

                  If your SlingPlayers have SlingID selected in the Directory entry for your Slingbox, no changes are required.  The SlingID servers will pick up the change pretty quickly and everything should start pointing to the correct place.

                   

                   

                  Post back and say how it goes.

                   

                   

                  Oh, one more thing... I don't mean to knock the previous post, but I don't think putting the Slingbox on a light timer to force a routine power cycle is going to help with this.  When the Slingbox reboots, it's still going to have the same settings and nothing is accomplished.  Now if the router is going goofy and frequent reboots prove to be a temporary fix, that's different.  If it came to that though, I'd be hauling *** to the store to buy a new router. 

                   

                   

                  Hope this helps,

                   

                   

                  - Az