13 Replies Latest reply: Dec 4, 2011 4:54 AM by OvCollyer RSS

    Slingcatcher problem

    Ondvegi

      Hi

       

      I have two Slingbox Solo´s here in Iceland , connected to a "Planet" switch which is connected to a Zyxel P-660HW-D1 router. I use port 5002 and 5003 in the port forwarding settings in the router. When I use "sling.com" to watch them slingboxes, it works fine!

       

      But now I am staying in Spain for a holiday, with my slingcatcher, but it doesn´t connect to my slingboxes "Sorry, there was an network error"......

       

      I have updated the firmwares in all three devices, i.e. the two slingboxes and the slingcatcher.

      I even have reset them all to factory settings to set them up again, with no luck.

       

      Can somebody help me please?

       

      best regards

      Valur

        • Re: Slingcatcher problem
          callanish Apprentice

          In Spain, can you still connect to both your slingbox's in Iceland with a computer? Are you sure you're running a TCP stream from the slingbox? If running webplayer to watch your slingbox press ctrl on the keyboard and click the video stream, a box will come up. Look for stream type. If its SNATT or RELAY there's your reason for the connection error. You said you port forwarded, do any sling warning signs come up when you go to this page and sign in.

           

          http://support.slingbox.com/go/home

           

          If you've got a TCP stream, which is required for the slingcatcher to connect, and no warning issues when you look at your current sling status, then the problem obviously lies elsewhere. So far, the above is my guess on your issue.

            • Re: Slingcatcher problem
              Ondvegi

              Hi Callanish, thanks for the answer

               

              When in Spain, it works fine with a computer, but neither one of the slingboxes work in the slingcatcher.

               

              I´m not sure what you´re talking about: "Are you sure you´re running a TCP stream from the slingbox?" , when I was configuring the port forwarding in the router , I selected both TCP and UDP, are you talking about that or something else? please explain if you are talking of something else.

               

              The stream type says relay, what do I do to change this? or what do I have to do,  to fix this?

               

              When I go to "http://support.slingbox.com/go/home"  , there is only one warning at the other slingbox "Slingbox status alerts: Slingbox software status: warning" , and its a link, and when I click it , it goes to this link: http://support.slingbox.com/get/KB-1000068 , but I just updated the slingbox.....the software version says: Slingbox Software Version: 1.3.70

              Otherwise it has no warnings.

               

              The other slingbox has no warnings. The software version says: Slingbox Software Version: 2.1.180

               

              And other strange thing is, I configured the other slingbox to go through port 5002, and the other one through 5003, but when I go to "http://support.slingbox.com/go/home" , it says: "Slingbox port 5001" in both the slingboxes. Do you know what the problem might be? and do you have any suggestions?

               

              Please could you check this for me and reply as soon as possible.

               

              thank you

               

              best regards

              Valur

                • Re: Slingcatcher problem
                  callanish Apprentice

                  From what you've said, whether you've port forwarded your router settings or not, both slingbox's aren't recognizing the port forwarding as being done correctly. The proof of this is the fact that you're running a relay stream and not a TCP stream. As long as you are running a relay stream or SNATT stream, your slingcatcher will have nothing but problems in trying to connect to your slingbox. Your status info on the home page showing two slingbox's running the same port forwarding number is also strange. I've got two slingbox's on the same network, both running on port 5001 and 5002 and it shows up this way correctly under slingbox status. The slingbox will use a fall back position ( SNATT or RELAY ) to connect when it fails to work with whatever port forwarding settings you have setup in your router. The slingplayer and webplayer can work with a SNATT or RELAY stream, the catcher can't.

                   

                  In order to try to solve this, you'd need local access to your network or have remote software, like logmein, running on a computer at your slingbox location so that you can take this computer over remotely in order to access your router / slingbox settings on your local network and attempt to fix the problem ( or have a router with remote access capabilities). I would check your router settings to make sure you didn't assign the same IP address accidently to both slingbox's when you setup port forwarding. The issue of one of your slingbox's not upgrading to the latest 2.1.180 firmware being stuck on 1.3.70 is also peculiar, but in order to troubleshoot, being in Spain while your slingbox's are in Iceland will make things difficult to solve.

                   

                  If I was in your situation and wasn't connecting to my slingcatcher, but had to wait until I got back to Iceland to try to fix the issue, I'd have to start from scratch and deal with one slingbox at a time by removing one of them from the network, then access the router and delete both port forwarding settings, then reset the slingbox, re-run the setup using manual port forwarding for internet viewing, assign a port number and IP address to the router, and then verify that internet viewing was done successfully. If internet viewing has been completed successfully according to the sling setup on the first slingbox, run the slingplayer desktop or webplayer, check the stream type and see if you've got a TCP stream. then do the same thing for the other slingbox while making sure the firmware on that slingbox has been upgraded to the latest version. You need to get back to basics here, unfortunately being so far away from both your slingbox's will limit your ability to address the problem.

                   

                  Whether you agree with my input or not, I guarantee you that if you aren't seeing TCP under stream type, you won't get around this network connection problem you are having with your slingcatcher.

                    • Re: Slingcatcher problem
                      Ondvegi

                      Hi Callanish

                       

                      thanks again for your answer.

                       

                      I began to reset the slingboxes and configuring the port forwarding from  start, both slingboxes are now with the latest  update and are port forwarded correctly.

                       

                      I have found out the problem from your suggestions. The problem was that the firewall in the zyxel router was blocking the TCP stream. When I turned off the firewall in the router, the slingcatcher worked, so I´ll have to make exceptions in the firewall.

                       

                      thank you for your help.

                       

                      best regards

                      Valur

                      • Re: Slingcatcher problem
                        jantje

                        Hi Callanish,

                         

                         

                        I got the same problem.....please advise how to change the streaming type from SNATT into TCP streaming ???

                          • Re: Slingcatcher problem
                            callanish Apprentice

                            To be honest, I'd need to know some info about what hardware you are using, how you originally setup your slingbox ( was it through the online setup ) and if you've already done the basics for setting up internet viewing, like providing a static local IP address for your router using port forwarding.

                             

                            Did you try to look at sling's video on how to setup internet viewing successfully through your router?

                             

                            http://support.slingbox.com/get/network-assistant.html

                             

                            In order to successfully change the slingbox stream from SNATT or RELAY to TCP, you'll need to access your router, understand how port forwarding / mapping works, provide the router with a static IP address and re-run the slingbox internet viewing setup and verify its success by testing the stream type either through the slingplayer desktop ( press alt.shift.i on the keyboard for stream type ) or ctrl and click the video stream for the webplayer. There could be variable reasons for why you aren't seeing a TCP stream, including from this thread, a possible firewall issue, but until I know the specifics and what you've already tried, I can only steer you in the right direction.

                              • Re: Slingcatcher problem
                                jantje

                                Hi,

                                Thanks for your reply.I change the Relay to TCP and disable the firewall but still not working.

                                 

                                Works on the laptop ok.

                                 

                                Ger

                                • Re: Slingcatcher problem
                                  podo12

                                  I'm having the same problem...Slingbox in Illinois, Slingcatcher in Nevada.

                                   

                                  I can watch the slingbox on everything except my Slingcatcher.

                                   

                                  I remoted in to my network in Illinois, tried to setup internet viewing again, got the "internet viewing is almost complete" screen

                                  I then set-up TCP port forwarding (my router calls it a pin hole) assinging it to port 5001 and using the IP address that was displayed by the telnet screen.

                                  I reset the router and checked that the forwarding was still there

                                   

                                  I then ran the internet viewing setup again and got the same "internet viewing is almost complete" screen

                                   

                                  When I test the stream to my PC in Nevada it is streaming as SNATT

                                   

                                  I've tried the manual instructions, but there are none for my "weird" router (netopia 3000)

                                   

                                  What am I missing?

                                  • Re: Slingcatcher problem
                                    jamesmccourt Novice

                                    Hi there,

                                     

                                    I am using the HDS-600RS and can access it remotely on my PC using both slingbox.com and an old version of Slingplayer.

                                     

                                    I noted that I am using a Relay feed and I guess this is why my Slingcatcher won't connect?

                                     

                                    If I am streaming OK then can I just remotely access my router and select 'TCP' without having to re-enter all the IP addresses and Port numbers?

                                     

                                    As I'm watching fine on my PC I don't want to incorrectly configure the router and lose the feed all together!

                                     

                                    Thank in advance.

                                • Re: Slingcatcher problem
                                  OvCollyer Apprentice

                                  In my experience there must be more to the way it chooses SNATT than it just being a fallback,

                                   

                                  My situation is I have a Slingbox Pro HD in London and a Netgear DG834 router with UPnP enabled and showing the SB has requested port 5001 be opened in TCP only. There are no additional port forwarding rules.

                                   

                                  When I connect from Slingplayer desktop on Windows, from a remote location, it shows as using a SNATT stream. The same is true for the Slingplayer Web plugin.

                                   

                                  However from the same local nework I am able to stream from the Slingcatcher?

                                   

                                  This suggests that Slingcatcher is using TCP (my understanding is that it can only use TCP) but the PC must have explicitly chosen SNATT. SNATT gives a slightly faster bitrate than the SC can obtain so maybe that is the reason it chose it?

                            • Re: Slingcatcher problem
                              admglrh

                              I'm in Norway having the same problem with a box in the UK. /go/home says everything is fine, port forwarding in place etc, player on the laptop is OK, but Catcher 'cannot connect due to a network error'. What next? This is very irritating!

                              • Re: Slingcatcher problem
                                DulceAndGabana

                                Hello I have the same issue,I did  deactivate the firewall still nothing happened.