11 Replies Latest reply: Jun 4, 2010 8:25 PM by JohnGrillman RSS

    I cannot get my Remote Control to display even after reloading the Slingplayer

    JohnGrillman

      Using my version 1.5.0.325 version of SlingPlayer while on a recent trip, the "Show Remote Control" function was grayed out (Alt-R) and I could not control my cable box to watch television.

       

      This was on a box that had worked well for close to three years.

       

      I let it go and was still the same when I got home - if I turn on the box manually, I see it fine through the SlingPlayer.

       

      I have another desktop I never put the SlingPlayer on and did so today. I loaded the 2.0.4.521 version, which included upgrading my firmware and the same thing occurred. I cannot display the remote and control the box. If I turn on the cable box manually I can see everything fine.

       

      When I set up the 2.0 version though I saw a distinct problem - when using the setup assistant I cannot select my Scientific Atlantic Explorer 8300 Cable box DVR - when I get to:

       

      1. Configure Video Sources
      2. Who manufactured your cable box, I only get two choices - "Other" or "Select" - there are no manufacturers listed to select
      3. What is the model? - is grayed out
      4. The prior screen - I select Cablevision for my local and the correct channels are listed two screens later under "We've determined your Channel Line-up"
      5. However when I get to the screen for configuring my Remote Control IR device, it again offers me no choices - only says "Custom" and I have no IR Code to enter and no way to no what it is
      6. So I cannot perform the "Power" test successfully or the channel changer test successfully

       

       

      It is obvious this stems from the fact I cannot select the Explorer 8300 for Cablevision. I cannot get two computers to work so this appears to me to be either the SlingPlayer or Cable box DVR (which I both powered on and off today) and the cable box seems to be working fine otherwise.

       

      Has anyone seen this and no how to fix?

       

      I am dismayed that SlingMedia is now charging $29.95 for a call only telling you ways you will have to pay multiple charges for the same problem while the web site troubleshooting only offers the basic steps for configuring which is fine when everything works but not real troubleshooting of this problem.

       

      Thanks 

        • Re: I cannot get my Remote Control to display even after reloading the Slingplayer
          agoddard

          I am having the exact same issue with my Comcast/Motorola DCH3416 cable box even though the widget on the website assures me it is fully supported. I posted question about it in the Setup forum. This is clearly a Slingplayer software issue, even though I am running the latest version of Slingplayer and the firmware.

           

          if I do select 'Other' and try to manually enter remote codes which I found through googling, the Slingplayer software merely replies, "Remote Control invalid,' no matter what code I enter.

            • Re: I cannot get my Remote Control to display even after reloading the Slingplayer
              turdferguson

              Regarding "Other..." manual alternative remote codes and Remote Code Invalid...

               

               

              The manual entry "code" Slingbox is expecting isn't actually a code as much as it's a filename.

               

              With a universal remote, you generally consult a table that has a big list of device type/manufacturer/model entries and their corresponding codes.  The code is a simple numeric sequence that is typed into the remote after entering a programming mode.  That code tells the remote to find and use a specific profile stored in it's ROM -- basically, a FILE -- to figure out what signals to send and how to do it's job.  As long as the code is accepted (i.e. file is found) by the remote and it's the correct one for your device, everything just works.

               

               

              This is exactly how Slingbox works.

               

               

              The nuts and bolts of the device selection + IR Blaster system on Slingbox is virtually identical to how all-in-one universal remotes work.  The main difference is instead of having a published lookup table with a bunch of short numeric codes for many devices, we have menus and pick-lists in the Slingbox setup assistant app.  When you choose your DVR, Cable Box, TiVO, whatever-box during configuration, the setup assistant tells your Slingbox which specific remote control profile to use.  I suppose you could think of it as "typing in the code" on an all-in-one because that's essentially what is happening.  And just like the all-in-one remotes, those profiles are preloaded and stored in the device at the factory.  It's part of your Slingbox firmware.  The cool thing is that unlike an all-in-one, Slingbox gets new remote control profiles once in awhile as part of firmware updates.

               

               

              There's also a second way to add a new remote profile on the Slingbox... which brings us back to "Other..." manual codes:

               

               

              If you have a properly compiled remote control definition file for your device, it can be uploaded to the Slingbox by the setup assistant.  That's what the alternative manual code entry box is for.  Basically, it wants a filename.  It does NOT want a 3 or 4 digit code like what one would program an all-in-one with.  Looking for remote codes on Google isn't going to get you anywhere I'm afraid.

               

              I don't think this feature is meant for public consumption and I'm unaware of any remote control .bin files available from Sling.  I consider the alternative code entry box found when selecting Other to be something like the USB port on the back of the Pro HD- it's there in plain sight, but it doesn't do anything. 

               

               

              Cheers,

               

              - TF

            • Re: I cannot get my Remote Control to display even after reloading the Slingplayer
              agoddard

              There is a similar discussion at https://community.sling.com/message/1745#1745

               

              I made this post there as well:

               

              I called the Slingmedia Support  line and they nicely gave me a one time exception on paying the $30  service contract fee for this issue. They said that since I had seen the  erroneous error message about the box not being made for use in the  USA, the next step was to unplug all the video and audio cables form the  Slingbox and reset the slingbox. Then I had to go through the Setup  Assistant again and see if it gave me the same error message without the  cables attached. If it did, I was to call them back and then they would  walk me through troubleshooting from there, and they would need to get  information from me such as the IR blaster version, which can be found  in the Slingplayer software.

               

              Unfortunately, I live overseas and cannot be at  the box to perform these steps, so now I am stuck. If anyone else has a  similar issue, please call the support line and walk it through to a  solution and then post the solution here so we can see it. My hope is  that a solution can be indentified that I can implement from here.

              • Re: I cannot get my Remote Control to display even after reloading the Slingplayer
                JohnGrillman

                Epilogue - Sorry  have not posted this sooner but have been busy - but a few weeks ago after I called SlingMedia a second time, I explained how I tried every suggestion I could find in the forum to no avail and how this has to be a systemic defect. I was told this was a problem but the tech thought it was solved and not being experienced by customers anymore. I explained, no that was not true - people were still posting occurances of this. The tech then got dispensation to help me with waiving the fee and helped me confirm my firmware was truly corrupt and my box was toast. They made good and I was able to get a swap and and a refurbished replacement that is NOW working again !!!!

                 

                So I would  say though there have been complaints about SlingMedia's support and I got extremely angry at the first tech I spoke with, once I called back a second time and re-explained everything they made good.