0 Replies Latest reply: May 27, 2011 6:17 PM by 255909770577861 RSS

    WebSlingPlayer & Dish 922: Does not work in home network, only internet. Any clue?

    255909770577861

      I am not able to get the SlingPlayer pluging to work when it is connecting in direct mode, that is, within my own internal network. It works fine when it has to go out to the internet and then back in. 

       

      My setup:

       

      * Windows XP, SP3 on a laptop connected via Wireless to home network.

      * Dish 922 receiver running on wired home network. Network is 192.168.1.x, sling box has dedicated IP at 192.168.1.240

       

      Scenario 1

      I had my wireless router setup to create a second network in my house to run in 192.168.3.x. When I connected my laptop to this network, I ran WebSlingPlayer and I *was* able to get a connection and it worked. I looked at the log file and noticed it actually went out to the internet and connected to my 922 using my external IP address. I am assuming this is because the UDP discovery request did not hop over to the 192.168.1.x network. All of this worked fine.

       

      Scenario 2

      I flattened my wireless network and put it on the same 192.168.1.x network so my laptop would be on the same network as the 922. When I ran WebSlingPlayer, I get an error saying it could not connect to my sling player with error (2). I looked in the log file and it shows it found the player on my internal network and tried to connect to it directly and failed. Thus, trying in "direct" mode did not work.

       

      Here are the key take aways from the log files....

       

      Working log: This shows the log file that worked where it went out to the internet. I masked my IP address.

      00:00:03.469  00000840  SBDEVICE: CSBDevice::ConnectTo : IP: 71.252.xxx.xxx, Port: 5101, Direct: 0

      00:00:03.469  00000840  SBDEVICE: CPS : Next Connection mode attempt : SNATT

       

      I used a file comparison program to see what differences I could pull out from the "broken" attempt versus the one that worked. Here is what I found.

       

      Broken log:

      00:00:02.750  000014C0  SBDEVICE: CSBDevice::ConnectTo : IP: 192.168.1.240, Port: 5101, Direct: 1

      00:00:02.750  000014C0  SBDEVICE: CPS : Next Connection mode attempt : TCP

      ...

      00:00:02.750  000014C0  SBDEVICE: connecting 192.168.1.240 : 5101
      00:00:02.750  00001264  SPIMPL  : OnStatusChange: 9
      00:00:02.750  000014C0  SBDEVICE: non-direct and non-local discovery direct: 1   local_discovery_ref: 00000000
      00:00:02.750  000014C0  SBCONCTN: addr:  192.168.1.240 intf: 192.168.1.3
      00:00:02.750  000014C0  SMSOCKET: CSMSocket DTOR : sock : -1   Control
      00:00:02.750  000014C0  SMSOCKET: CSMSocket DTOR : sock : -1   Control
      00:00:02.750  000014C0  SBCONCTN: SlingNet: Connecting with socket type: 0
      00:00:02.750  000014C0  SMSOCKET: CSMSocket CTOR : Control

      ...

      00:00:02.750  000014C0  SBCONCTN: CSBConnection::GetSetBestRoute - Enter: Inteface = 192.168.1.3 Destination = 192.168.1.240
      00:00:02.766  00001264          : Failed to fire on connection mode changed event
      00:00:02.766  00001264          : CSlingPlayerPlugin::OnConnectionModeChanged  : Failed to fire connection mode changed event.

      ...

      00:00:02.766  000014C0  SBCONCTN: CSBConnection::GetSetBestRoute AddRoutingEntry result = Success

      ...

      00:00:02.766  000014C0  SMSOCKET: Created new socket : 1188 Control
      00:00:02.766  000014C0  SMSOCKET: CSMSocket::OnDataEvent (FD_CONNECT : 4a4) : Error = 0x0315ffec socket: 1188  Type = Control
      00:00:02.766  000014C0  SBCONCTN: ISMSocket::notifyConnected [Control]
      00:00:02.766  000014C0  SBCONCTN: OnSocketConnected(): hr=00000000 {Type = Control)
      00:00:02.766  000014C0  SBREQST : CSBMessageRequest BORN - 03166F70
      00:00:02.766  000014C0  SBDEVICE: --[SLING_MSG_SESSION_OPEN_SB]: usSessionId: 0  uiMsgCookie: 1  uibfLength: 200 uibfCtl : 2
      00:00:32.766  000014C0  SBREQST : REQ_MESSAGE TIMEOUT : msg_type : 103

      ...

      00:00:32.766  000014C0  SBDEVICE: Error occured for connectiontype: TCP, Error:0x92340011

      ...

      00:00:32.766  000014C0          : slingbox_offline_hint : 0
      00:00:32.766  000014C0  SBDEVICE: ### CSBDevice::SignalClose: LAN - box  : ; ip : ; port: 0; finder: [C1FDB7CEA87D654A880C85417F7C3F65]
      ...

      00:00:32.766  00001264  SPIMPL  : CSlingPlayerImpl::OnDeviceNotification : code : 33
      ...

      00:00:32.766  000014C0          : slingbox_offline_hint : 0
      ...

      00:00:32.766  00001264  SBSERVIC: Device connect request completed...
      ...

      00:00:32.766  00001264  SBSERVIC: Request failed with Error Code: 92340011, (null)
      ...

      00:00:32.766  00001264  SBSERVIC: Service 6 failed with error 0x92340011
      ...

       

      From there it is just some analytical stuff. I also attached the full broken log file if that helps. Does anyone have an idea what is going on? This is very frustrating.

       

      Sling works via my iPad using the same wireless network but I am not sure if it is staying internal or external on my networkk.

       

      Robert