12 Replies Latest reply: Aug 16, 2011 8:16 AM by jharrison RSS

    Cannot connect outside my own wifi

    ACC713393

           My Slingbox will work fine on my computer, iPad and iPhone while on my own local wifi network.  However when I try to connect via 3G or on another wifi network with any of the same devices it says "SlingPlayer cannot connect to your slingbox.  Please make sure your slingbox is connected to the internet and try again." 

       

      I have checked for updates, uninstalled and reinstalled app, reset router, nothing changed.  It use to work fine on the same network, just started messing up out of nowhere a month ago.

       

      Help?

        • Re: Cannot connect outside my own wifi
          technorev

          I'm having the same problem.  I used to have no problem accessing my Slingbox with my IPhone and IPad using my 3G setting.  Now, it only works when I'm at home.  I hope someone answers your question, that is my question too.

           

          Thanks for asking

          • Re: Cannot connect outside my own wifi
            Gladitude

            I am having the exact same problem. You all describe it very well.

            Has anyone seen an answer to this situation??

            FYI - I have the new Verizon iPhone and an AT&T 3G iPad. No luck on either of them all of a sudden.

            • Re: Cannot connect outside my own wifi
              technorev

              OK, my Slingbox Classic is now working properly, and I can watch it on my IPad and IPhone away from home.  I read somewhere on this site that you need to restart the installation program.  That is true.  Also, when you open Slingbox, go to the Window tab, select Slingbox Directory and choose Change Network Settings.  Now, because I don't want to fix what is not now broken, I am not trying to go through the steps again to make sure I have each thing exactly correct.  However, I will say you should follow the prompts.  Also, go to your router and make sure that your port forwarding is set properly.  You need to get the MAC Address and the IP Address for your Slingbox from your router.  Set the port forwarding to 5001 Start and 5001 End.  Choose to Enable TCP.  Now the only part I'm fuzzy on is how I got to the manual setup page.  I think it started when I went to the Slingbox Directory and chose Change Network Settings.  In any event, the process worked, and I'm back up and running.  I hope this helps.

              • Re: Cannot connect outside my own wifi
                iLuvgeek

                I think I have solved the problem.

                 

                Once you are sure that you can connect to your slingbox over the internet, re-boot (not just standby) your iOS device. A standard shutdown will suffice; hold standby untill you see the slider then slide to power off. Wait 10 seconds then hold the standby button for 2 seconds to turn it back on. If that doesn't fix it try a hard restart: Hold standby and home, ignoring the slider,  until the phone restarts on it's own (about 12 seconds). See video: http://youtu.be/eaO2K70M14w

                 

                My testing implies that if you are watching the slingbox on wifi and it switches to 3G, it will never work on 3G untill you re-boot (I say implies because I have not done enough testing to prove it).

                  • Re: Cannot connect outside my own wifi
                    slingbox1977

                    Hi, I have the same problem. I've been using slingplayer for iphone on my iphone and ipad without issue for several months. Recently, I cannot connect to my slingbox over 3G but over wifi it is fine.

                     

                    I was really hoping that resetting the IOS device as described would solve the problem but alass it has not worked!

                     

                    I tried both soft and hard resets to no avail - just get the 'slingplayer cannot connect to your slingbox' message. If I go back tgo my wifi network it connects straight away!

                     

                    What else can I try to fix this?

                     

                    David