3 Replies Latest reply: May 24, 2011 7:17 AM by alanrichey42 RSS

    Fixed Incorrect Remote Display

    MTFrobin Newbie

      I see lots of people are having the same problem where the Comcast remote is suddenly showing up instead of the right one.

      It's been going on for a month now, but today finally they added the Scientific Atlantic remote!!!

      To find it you have to put SlingPlayer in full screen mode and click on menu just above the remote itself.

      The problem is that it seems The Sling Staff only half fix it. The Comcast remote seems to be the default remote and you can not delete it.

      So everytime you start the player you have to change the remote to the correct one.

       

      I hope Sling will continue to fix this major problem ! ! ! ! ! !

       

       

      I found out how to fix the problem from reading another thread but the directions were incorrect.

      All you need to do is go in to your file directory and navigate to:

       

       

      For Windows XP

       

      My Computer

       

      C:\Documents and Settings\All Users\Application Data\

          Slingmedia\Slingplayer\2.0\Remote

       

       

      For Vista and Windows 7  (32 or 64 bit)

       

      Computer

       

      C:\Program Data\Sling Media\SlingPlayer\2.0\Remote

       

       

      Now all you need to do is delete all .spr files except TimeWarner.spr

      (depending which remote you need)

       

      or just delete all and run Sling setup for Configure Video Sources.

       

      You need to do this on all devices you use to watch Slingbox except windows mobile apps.

       

      Hope this helps everyone!

        • Re: Fixed Incorrect Remote Display
          alanrichey42 Master

          Very useful post, thanks.  But I would make a couple of comments/additions:

           

          1.   The path for Vista & Windows 7 is actually:

           

               C:\ProgramData\Sling Media\SlingPlayer\2.0\Remote  

               (No space between 'Program' and 'Data')

           

               and you need to go to Windows Explorer and select :

           

              Organise > Folder and Search Options > View (Tab) > Show Hidden Files and Folders  

           

              to see that folder.

           

          2.   I suspect you only need to delete the Comcast.spr file, but it does no harm to delete them all as Slingplayer will subsequently download the ones it needs.

           

          3.  The appropriate path for the MAC is /Applications/SlingPlayer/Contents/Resources/Remote

           

                 (Note that The Contents dirs won't show up unless you do a "Right-Click -> Show Package Contents" when navigating into an app's "Contents" directory.)

           

          4.   All these paths are for the standalone Slingplayer.   You might find you have to do the same trick for the web-based player.  The paths are:

           

              Vista & WIN7
              C:\Users\..<User>..\AppData\Roaming\Sling Media\WebSlingPlayer\Remote

           

              WINXP
              C:\Documents and Settings\<user>\Application Data\Sling Media\WebSlingPlayer\Remote\

           

              MAC

              \user\library\Application Support\SlingMedia\Remotes\

           

          Al

            • Re: Fixed Incorrect Remote Display
              MTFrobin Newbie

              Yes your right I forget that the first thing I do is use Classic View in Windows Explorer in Windows 7.and show hidden Folders and Files.

              I just checked all my windows 7 machines and all 5 have a space between Program Data and Sling Media and no spaces on everything else.

              I guess it depends how you have Windows Explorer configured either way is OK.

              Thanks for adding the Mac info

                • Re: Fixed Incorrect Remote Display
                  alanrichey42 Master
                  I just checked all my windows 7 machines and all 5 have a space between Program Data and Sling Media and no spaces on everything else.

                  How odd.   All three of my WIN7 machines definately show C:\ProgramData\....    But I haven't done any configuration changes so maybe your "Classic View" makes the change.

                   

                  Cheers

                   

                  Al