16 Replies Latest reply: Jun 27, 2014 2:56 AM by freekmccoy RSS

    Port Forwarding to 443

    Saramj

      I recently downloaded the SlingPlayer for my iPod touch and I cannot connect at my office. If I remember correctly from an old laptop I had I was given advice on having the 5001 port forwarded to 443 on my home network so my office network would think the signal is coming from 443 (which is usually always open). I can no longer find the documentation on how to and what ports on my router to forward. I already have a port forwarded entry (which I assume was set up by the sling software when I set up Internet viewing) called Slingbox with an external port of 5001 and an internal port of 5001 with both selected under the protocol. I am able to connect from other open wifi sites. I am using a Linksys WRT310N router.

        • Re: Port Forwarding to 443
          ArizonaSackbut Apprentice

          Hi Saramj,

           

          Moving to Port 443 is probably easier than you think.

           

          You mentioned that your router's port forwarding options include external and internal ports as configuration options.  It might be possible to have the external set to 443 and the internal set to 5001 and make no changes at all to your Slingbox or Players.  If so, cool !  However I'm concerned that things could break down if your Slingbox and the SlingID finder service don't quite figure things out though.  No harm in trying- if it doesn't work, follow the steps below...

           

           

          There's one condition, one assumption and two changes required to make this happen.

           

          Condition: You need a clear path from the remote network to your home.

          That means your remote network and home ISP need to allow traffic on 443 in both directions.  You can control and configure your computer, router and Slingbox to "clear the path."  You likely don't have control over what the remote net and your ISP are doing, so that part needs to be clear on it's own or this won't work.

           

          If you're interested (and don't already know), Port 443 is normally used for HTTPS secure web traffic.  Here's a link with a more complete explanation:

          http://www.grc.com/port_443.htm

           

           

          Assumption: Your Slingbox is already set up and working at home.

          I'm only covering how to change your port in this post.

           

           

          Change #1: Tell your Slingbox to move from Port 5001 to 443

          Slingbox uses 5001 by default.  You can manually change this using the setup assistant in SlingPlayer.

           

          These directions are for the Mac OS X version of SlingPlayer.  If you run Windows, your version of SlingPlayer will be similar.

           

          In SlingPlayer, go to Window > Slingbox Directory, select your Slingbox then choose Edit.  Next, choose Configuration and then Change Network Settings.  This will start the network assistant, and you'll need your admin password.  One of the first questions will ask if you want to set up remote viewing.  Choose yes and proceed.  When you get to the router configuration screen, choose Manual (Advanced). Here's a screen shot:

           

          RouterConfig1.png

           

           

           

          Next you'll get a screen where you can enter the Slingbox IP, Subnet and Router IP.  If you have previously set up your Slingbox and it's working, this information should already be entered and no changes are required.  Make note of the IP Address, you may need it in a few minutes. Once you have written it down, just click Continue to proceed.  Please note, the IP addresses and subnet you see in the screenshot are examples only, you should not need to change your entries.

           

          RouterConfig2.png

           

           

           

          After that, you get to change your port !  Switch 5001 to 443 and click Continue.

           

          RouterConfig3.png

           

           

          Finish up and accept the changes.  That's it for Change #1.

           

           

           

          Change #2: Adjust your router's port forwarding rules

          No fancy screenshots this time, sorry.

           

          Log into your router, find the port forwarding tab, and look for the Slingbox rule for 5001.  Change that to 443.  If your router has options for external and internal ports, both should be set for 443.

           

          If you have not previously created a port forwarding rule, make a new one now.  The idea is to send traffic on 443 to your Slingbox IP address.  That's why I suggested writing it down earlier.  If you have to choose between TCP, UDP or BOTH, go with BOTH.

           

          Save the changes and that's it.

           

           

           

          Your Slingbox is now parked on Port 443 and if the end-to-end path is clear like I mentioned near the top, you should be able to watch TV at the remote location now. 

           

           

          If your Players are using SlingID to find your Slingbox, the changes will get automatically updated quickly and the SlingID will start pointing to the correct place.  If any of your Players are manually configured, you'll need to adjust them for the new port.

           

           

           

           

          Hope this helps,

           

          - Az

           

            • Re: Port Forwarding to 443
              Buzzhd

              what's the advantage for changing from port 5001 to 443? I remember default on slingbox is port 5001. Does it make any difference? I haven't tried yet, but thinking I should as I am having problem running slingplayer on ipod touch 2g over wifi connection. I have full wireless signal, set low quality video and audio, still having problems like frozen after 10 seconds etc.

               

              Honestly I tried slingplayer (trial version) on my blackberry 8900 a while back, it worked perfectly, so true on my laptop. Therefore I think my router setting should be fine. Slingplayer for iphone/itouch defect? I may have to say so...

                • Re: Port Forwarding to 443
                  ArizonaSackbut Apprentice

                  Hi Buzzhd,

                   

                   

                  what's the advantage for changing from port 5001 to 443?

                  There is no advantage really, all port numbers work the same way.  The only reason someone would want to change away from Sling's default 5001 is because it is being blocked by something they can not control.

                   

                  For example: All of your computers, devices, Sling things and home network are working great.  You can connect and watch on your computer and phone from anywhere... except work.  Your company's network administrators decided to block both incoming and outgoing traffic on many ports for security, 5001 is one of them.

                   

                  Result: You can't Sling at work.  So, you move your Slingbox from 5001 to something open.  Port 443 is normally used for HTTPS secure web traffic, most places wouldn't want to shut that down.

                   

                   

                   

                  I am having problem running slingplayer on ipod touch 2g over wifi connection ... still having problems like frozen after 10 seconds

                  Changing ports is not going to help you.  Quality will not improve and nothing will go faster.  If you can watch your Slingbox over the internet from your computer without problems, there is nothing wrong with your port assignment, router, network or Slingbox.

                   

                   

                   

                  Hope this helps,

                   

                  - Az

                • Re: Port Forwarding to 443
                  hedaprakash

                  Can you post how to change default port for slimbox on windows 7?

                   

                  There is no way Slimbox letting me do change port manually cause its able to do internet viewing successfully, so it assumes all is well and user doesn't need to change it manually....and its working fine over internet but only from my office its not working fine since port 443 needs to be opened...

                   

                   

                  Went through all the clutter of articles but none of them talks about specifically changing port to 443 at slingbox

                  I am not worried about router port forwarding...so dont advice about that...

                   

                  All I need is steps to change slingbox port to 443 manually in windows 7 (Slingbox is able to configure internet viewing  fine)

                • Re: Port Forwarding to 443
                  Resist Newbie

                  I recently changed to port 443 after using port 5001 for months.  All of a sudden out of the blue I couldn't connect to my Slingbox via port 5001, when using 3G or WiFi out of my home network.  And while switching to port 443 fixed my problem (thanks to this forum), I am curious as to why port 5001 stopped working.  Interestingly, I noticed the issue after updating my the firmware in my Slingbox Pro HD, not sure if there is a connection.  Any ideas?

                    • Re: Port Forwarding to 443
                      ArizonaSackbut Apprentice

                      Hi Resist,

                       

                       

                      It's hard to say why 5001 went goofy on you, it could be a number of things.

                       

                      Maybe the ISP decided to disallow 5001 in one or both directions.  It could be the ISP on either end, and wifi counts because the net admin might have done the same.  It's one thing if you're on a friend's wireless net, something different at work or on a public hotspot.

                       

                      Tracking down exactly what happened will likely just end up with you eliminating the things you can control from suspicion.  Take your best guess from whatever is left.

                       

                      443 is used normally for HTTPS traffic, so people aren't as trigger happy to shut that down.

                       

                       

                      As far as your firmware update goes, I'd say it's a little suspicious but remember that correlation does not equal causation.

                       

                       

                       

                      Happy trails,

                       

                      - Az

                        • Re: Port Forwarding to 443
                          verakot

                          Why port 443? Are there any other ports that can be used if changing from 5001 and 443 does not work?

                            • Re: Port Forwarding to 443
                              ArizonaSackbut Apprentice
                              Why port 443? Are there any other ports that can be used if changing from 5001 and 443 does not work?

                               

                              Any port can be used.  It's arbitrary- choose whichever one you like.  As long as the path between your viewing device and Slingbox isn't blocked  or conflicted anywhere, it'll work.

                               

                              There's no set list or range of ports that work in all situations because success depends on the network you're viewing from, the ISPs involved on either end and your router/Slingbox settings.  The equipment at home is the only thing regular users typically have control over.

                               

                               

                              5001 is the default port used by Slingbox.  Most of the time this works great.

                               

                              443 is normally used for secure web (HTTPS) traffic.  As such, it's usually not intentionally blocked which makes it a reasonable alternative when slinging from restrictive networks.  Many folks have had success slinging from work or other managed networks on 443 when 5001 is being blocked.  However, it doesn't always work and it's not the only option.

                               

                               

                              Hope this helps clear it up

                               

                               

                              - Az

                          • Re: Port Forwarding to 443
                            Bryanod Novice

                            It most likely has to do with your router.  Upnp enabled routers use a uuid to identify the sling.  When you update firmware that uuid changes. So when traffic comes in on that port it can't be routed.    Rerunning the setup will update the upnp data on the router.  Not using Upnp and using a static ip and portforward like AZ shows will do the trick as well. 

                             

                            When you let the sling do the automatic configuration it takes port 5001 and routes that to the uuid.  With upnp unlike port forwarding the sling can use any ip address even virtual ones.

                            • Re: Port Forwarding to 443
                              gabrielle Newbie

                              Hey Resist,you still getting the "slow" 3g,or were you able to find a solution?Is the 3g still working?

                              • Re: Port Forwarding to 443
                                eferz Expert

                                Most likely it was either your service provider or WiFi hotspot blocking that port or using that port for their own nefarious reasons.  But then, that's why Sling allows you to change the port.

                              • Re: Port Forwarding to 443
                                GaryMO Newbie

                                In my Slingbox Property Information tab, under the LAN section, it shows the port as 5001, when I have port forwarding set to 443 on my home router. Remote viewing works fine, I was just curious why I don't see port 443 anywhere in my information list.

                                • Re: Port Forwarding to 443
                                  ACC6067382

                                  This worked for me!!